Questo articolo descrive la sintassi della formula e l'uso della funzione ERRORE.TIPO in Microsoft Excel.

Descrizione

Restituisce un numero corrispondente a uno dei valori di errore di Microsoft Excel oppure restituisce l'errore #N/D se non vi è alcun errore. È possibile utilizzare la funzione ERRORE.TIPO all'interno di una funzione SE, in modo da determinare il tipo di errore verificatosi e restituire una stringa di testo, come un messaggio, invece del valore di errore.

Sintassi

ERRORE.TIPO(errore)

Gli argomenti della sintassi della funzione ERRORE.TIPO sono i seguenti:

  • Errore    Obbligatorio. Valore di errore di cui si desidera trovare il numero di identificazione. Sebbene errore possa essere il valore di errore stesso, si tratta in genere di un riferimento a una cella contenente una formula che si desidera verificare.

Se errore è

ERRORE.TIPO restituirà

#NULLO!

1

#DIV/0!

2

#VALORE!

3

#RIF!

4

#NOME?

5

#NUM!

6

#N/D

7

#ESTRAZIONE_DATI_IN_CORSO

8

Qualsiasi altro valore

#N/D

Esempio

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per visualizzare i risultati delle formule, selezionarle, premere F2 e quindi premere INVIO. Se necessario, adattare l'ampiezza delle colonne per visualizzare tutti i dati.

Dati

#NULLO!

#DIV/0!

Formula

Descrizione

Risultato

=ERRORE.TIPO(A2)

Numero dell'errore #NULLO! Errore(1)

1

=SE(ERRORE.TIPO(A3)<3;SCEGLI(ERRORE.TIPO(A3),"Gli intervalli non si intersecano.","Il divisore è zero."))

Controlla la cella A3 per verificare se la cella contiene il #NULL! o il valore #DIV/0! . In caso contrario, il numero per il valore di errore viene usato nella funzione del foglio di lavoro SCEGLI per visualizzare uno dei due messaggi. in caso contrario, viene #N valore di errore #D0 /D.

Il divisore è zero

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Quanto ti soddisfa la qualità della traduzione?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×