I report costituiscono un modo semplice per visualizzare, formattare e riepilogare le informazioni del database di Microsoft Access. È ad esempio possibile creare un report semplice per visualizzare i numeri di telefono di tutti i contatti oppure un report di riepilogo relativo al totale delle vendite in aree e periodi diversi.
Questo articolo offre una panoramica dei report in Access. Si apprenderanno anche le nozioni di base sulla creazione di un report, l'uso di opzioni come l'ordinamento, il raggruppamento e il riepilogo dei dati e su come visualizzare in anteprima e stampare il report.
Panoramica dei report in Access
Operazioni eseguibili con un report
Un report è un oggetto di database che risulta utile quando si desidera presentare le informazioni di un database per uno degli scopi seguenti:
- Visualizzare o distribuire un riepilogo dei dati.
- Archiviare istantanee dei dati.
- Fornire dettagli su singoli record.
- Creare etichette.
Parti di un report
Anche se è possibile creare report "non associati" che non visualizzano dati, questo articolo presuppone che un report sia associato a un'origine dati come una tabella o una query. La struttura di un report è suddivisa in sezioni che è possibile visualizzare in visualizzazione Struttura. Comprendere il funzionamento di ogni sezione può aiutare a creare report migliori. Ad esempio, la sezione in cui si decide di inserire un controllo calcolato definisce la modalità di calcolo dei risultati da parte di Access. L'elenco seguente riepiloga i tipi di sezione e i loro usi:
| Sezione | Visualizzazione della sezione nella stampa | Posizione in cui è possibile utilizzare la sezione |
|---|---|---|
| Intestazione di report | All'inizio del report. | Utilizzare l'intestazione di report per includere informazioni in genere riportate su una copertina, ad esempio il logo, il titolo e la data. Se nell'intestazione di report viene inserito un controllo calcolato che utilizza la funzione di aggregazione Somma, verrà calcolata la somma per l'intero report. L'intestazione di report viene stampata prima dell'intestazione di pagina. |
| Intestazione di pagina | Nella parte superiore di ogni pagina. | Utilizzare un'intestazione di pagina per ripetere il titolo del report su ogni pagina. |
| Intestazione di gruppo | All'inizio di ogni nuovo gruppo di record. | Utilizzare l'intestazione di gruppo per stampare il nome del gruppo. In un report raggruppato per prodotto utilizzare, ad esempio, l'intestazione di gruppo per stampare il nome del prodotto. Se nell'intestazione di gruppo viene inserito un controllo calcolato che utilizza la funzione di aggregazione Somma, verrà calcolata la somma relativa al gruppo corrente. In un rapporto possono essere presenti più sezioni di intestazione di gruppo, a seconda del numero di livelli di raggruppamento aggiunti. Per ulteriori informazioni sulla creazione di intestazioni e piè di pagina di gruppo, vedere la sezione Aggiungere raggruppamenti, ordinamenti o totali. |
| Corpo | Viene visualizzata una sola volta per ogni riga nell'origine record. | In questa sezione vengono inseriti i controlli che compongono la parte principale del report. |
| Piè di pagina di gruppo | Alla fine di ogni gruppo di record. | Utilizzare un piè di pagina di gruppo per stampare le informazioni di riepilogo per un gruppo. In un report è possibile avere più sezioni di piè di pagina di gruppo, a seconda del numero di livelli di raggruppamento aggiunti. |
| Piè di pagina | Nella parte inferiore di ogni pagina. | Utilizzare un piè di pagina per stampare il numero di pagina oppure informazioni specifiche per ogni pagina. |
| Piè di pagina di report | Alla fine del report. Nota: In visualizzazione Struttura il piè di pagina del report viene visualizzato sotto il piè di pagina. Tuttavia, in tutte le altre visualizzazioni, ad esempio la visualizzazione Layout, o quando si esegue la stampa o l'anteprima del report, il piè di pagina del report viene riportato sopra il piè di pagina, subito dopo l'ultimo piè di pagina di gruppo oppure l'ultima riga della sezione Corpo nella pagina finale. |
Utilizzare il piè di pagina di report per stampare i totali oppure altre informazioni di riepilogo per l'intero report. |
Per questo motivo, è molto più facile creare report significativi quando il database ha una struttura di tabelle e relazioni ben progettate. Per informazioni introduttive sulla pianificazione e progettazione di un database, vedere l'articolo Nozioni fondamentali sulla progettazione di database.
Creare un report in Access
È possibile creare relazioni per il database desktop di Access seguendo la procedura descritta in questa sezione.
Passaggio 1: Scegliere un'origine record
L'origine record di un report può essere una tabella, una query denominata o una query incorporata. L'origine record deve contenere tutte le righe e le colonne di dati che si desidera visualizzare nel report.
Se i dati provengono da una tabella o una query esistente, selezionare la tabella o la query nel riquadro di spostamento e quindi procedere con il passaggio 2.
Se l'origine record non esiste ancora, eseguire una delle operazioni seguenti:
- Continuare con il passaggio 2 e usare lo strumento Segnalazione vuota oppure
- Creare la tabella o la query che contiene i dati necessari. Selezionare la tabella o la query nel riquadro di spostamento e quindi continuare con il Passaggio 2.
Passaggio 2: Scegliere uno strumento Report
Gli strumenti per i report sono disponibili nella scheda Crea della barra multifunzione, nel gruppo Report . Nella tabella seguente vengono descritte le opzioni.
| Strumento | Descrizione |
|---|---|
| Report | Viene creato un semplice report tabulare contenente tutti i campi dell'origine record selezionati nel riquadro di spostamento. |
| Struttura report | Viene aperto un report vuoto in visualizzazione Struttura, al quale è possibile aggiungere i campi e i controlli obbligatori. |
| Report vuoto | Viene aperto un report vuoto in visualizzazione Layout e visualizza il riquadro attività Elenco campi in cui è possibile aggiungere campi al report. |
| Creazione guidata report | Visualizza una procedura guidata in più passaggi che consente di specificare campi, livelli di raggruppamento e ordinamento e opzioni di layout. |
| Etichette | Viene visualizzata una creazione guidata che consente di selezionare dimensioni di etichetta standard o personalizzate, nonché i campi che si desidera visualizzare e la relativa modalità di ordinamento. |
Passaggio 3: Creare il report
Seleziona il pulsante per lo strumento da usare. Se viene visualizzata una procedura guidata, seguire i passaggi della procedura guidata e selezionare Fine nell'ultima pagina. Il report verrà visualizzato automaticamente in visualizzazione Layout.
Formattare il report in modo da ottenere l'aspetto desiderato:
- Ridimensionare campi ed etichette selezionandoli e trascinando i bordi fino a ottenere le dimensioni desiderate.
- Spostare un campo selezionandolo, e selezionando la relativa etichetta se presente, e quindi trascinarlo nella nuova posizione.
- Fare clic con il pulsante destro del mouse su un campo e utilizzare i comandi del menu di scelta rapida per unire o dividere le celle, eliminare o selezionare campi ed eseguire altre operazioni di formattazione.
Inoltre, usare le funzionalità descritte nelle sezioni seguenti per rendere il report più interessante e leggibile.
Nota
A partire da Access per Microsoft 365 versione 2609 (build 16.0.20430.20146), un report può essere largo fino a 5.080 cm e ogni sezione del report può essere alta fino a 2.000 pollici. L'altezza combinata di tutte le sezioni e delle intestazioni di sezione può arrivare fino a 5.334 cm (2.100 pollici). Le versioni precedenti di Access mantengono i limiti precedenti di 22,75 cm (22,75 pollici) per la larghezza del report e l'altezza delle singole sezioni e di 200 cm (208 pollici) per l'altezza delle sezioni combinate. I rapporti che usano dimensioni maggiori potrebbero non essere compatibili con le versioni precedenti, pertanto verificare le versioni di Access usate da tutti gli utenti che aprono il database.
Se si aumenta l'area di progettazione del report, non aumenta l'area stampabile del formato carta selezionato. Usare le opzioni Anteprima di stampa e Imposta pagina per confermare come dividere il report in pagine. Per ulteriori informazioni, vedere Visualizzare l'anteprima e la stampa di un rapporto.
Aggiungere raggruppamenti, ordinamenti o totali
Il modo più rapido per aggiungere raggruppamento, ordinamento o totali a un report di database desktop consiste nel fare clic con il pulsante destro del mouse sul campo a cui si desidera applicare il raggruppamento, l'ordinamento o il totale e quindi scegliere il comando desiderato dal menu di scelta rapida.
È anche possibile aggiungere raggruppamento, ordinamento o totali usando il riquadro Raggruppamento, ordinamento e totale mentre il report è aperto in visualizzazione Layout o Struttura:
- Se il riquadro Raggruppamento, ordinamento e totale non è aperto, nel gruppo Raggruppamento e totali della scheda Struttura report selezionare Raggruppa & Ordina.
- Selezionare Aggiungi un gruppo o Aggiungi un ordinamento e quindi scegliere il campo in cui raggruppare o ordinare.
- Selezionare Altro in una riga di raggruppamento o ordinamento per impostare altre opzioni e aggiungere totali.
Per ulteriori informazioni sul raggruppamento, l'ordinamento e i totali, vedere Creare un report con raggruppamenti o di riepilogo.
Evidenziare i dati con la formattazione condizionale
Access include strumenti che consentono di evidenziare i dati in un report. È possibile aggiungere regole di formattazione condizionale per ogni controllo o gruppo di controlli e nei report client è anche possibile aggiungere barre dei dati per confrontare i dati.
Per aggiungere la formattazione condizionale ai controlli:
Fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento e quindi scegliere Visualizzazione Layout.
Selezionare i controlli desiderati. Nel gruppo Formattazione controlli della scheda Formato fare clic su Formattazione condizionale.
Suggerimento
Per selezionare più controlli, tenere premuto CTRL e fare clic sui controlli.
Nella finestra di dialogo Gestione regole formattazione condizionale fare clic su Nuova regola.
Nella finestra di dialogo Nuova regola di formattazione selezionare un valore in Selezionare un tipo di regola:
- Per creare una regola che valuti singolarmente ogni record, selezionare Controlla valori nel record corrente o usare un'espressione.
- Per creare una regola per effettuare il confronto tra record mediante barre dei dati, fare clic su Confronta con altri record.
In Modifica descrizione regola, specificare la regola per quando applicare la formattazione e quale formattazione applicare, quindi fare clic su OK.
Per creare una regola aggiuntiva per lo stesso controllo o set di controlli, ripetere questa procedura dal passaggio 4.
Personalizzare colore e tipi di carattere
Provare un'opzione Tema app per personalizzare il colore e i tipi di carattere.
- Aprire un report in visualizzazione Layout facendo clic con il pulsante destro del mouse su di esso nel riquadro di spostamento e quindi scegliendo Visualizzazione Layout.
- Nella scheda Progettazione layout report fare clic su Temi e posizionare il cursore sui vari temi della raccolta per visualizzare in anteprima gli effetti. Fare clic su un tema e quindi salvare il report.
- Utilizzare la raccolta Colori o Tipi di carattere per impostare colori e tipi di carattere separatamente.
Aggiungere un logo o un'immagine di sfondo
È possibile aggiungere un logo o un'immagine di sfondo a un report. Se si aggiorna l'immagine, Access aggiorna automaticamente l'immagine in ogni punto del database in cui viene usata.
Per aggiungere o rimuovere un'immagine del logo:
- Nel riquadro di spostamento fare clic con il pulsante destro del mouse sul report e quindi scegliere Visualizzazione Layout.
- Nel report, fare clic nella posizione in cui si vuole aggiungere l'immagine. Nel gruppo Intestazione/piè di pagina della scheda Progettazione layout report fare clic su Logo.
- Passare all'immagine e quindi fare clic su Apri. L'immagine viene aggiunta al report.
- Per rimuovere l'immagine, fare clic con il pulsante destro del mouse sull'immagine e quindi scegliere Elimina dal menu di scelta rapida.
Per aggiungere un'immagine di sfondo:
- Nel riquadro di spostamento fare clic con il pulsante destro del mouse sul report e quindi scegliere Visualizzazione Layout.
- Nel gruppo Sfondo della scheda Formato fare clic su Immagine di sfondo.
- Selezionare un'immagine dall'elenco Raccolta immagini oppure fare clic su Sfoglia, selezionare un'immagine e quindi fare clic su OK.
Visualizzare in anteprima e stampare un report
Visualizzare in anteprima un report
Fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento e scegliere Anteprima di stampa. Utilizzare i comandi della scheda Anteprima di stampa per:
- Stampare il report
- Modificare le dimensioni della pagina o il layout
- Fare zoom avanti o indietro o visualizzare più pagine contemporaneamente
- Aggiornare i dati nel report
- Esportare il report in un altro formato di file
Selezionare Chiudi anteprima di stampa.
Stampare un report
Per stampare un report senza visualizzarlo in anteprima:
Fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento e scegliere Stampa. Il report verrà inviato alla stampante predefinita.
Nota
Se si seleziona il report nel riquadro di spostamento e si seleziona Stampa nella scheda File , è possibile selezionare altre opzioni di stampa, ad esempio il numero di pagine e copie, e specificare una stampante.
- Per aprire una finestra di dialogo in cui è possibile selezionare una stampante, specificare il numero di copie e altro ancora, selezionare Stampa.