Introduzione
Questo articolo descrive i problemi risolti nell'aggiornamento cumulativo 20 per le versioni seguenti di Microsoft Azure Site Recovery:
- Provider di Azure Site Recovery Microsoft (versione 5.1.2550.0)
- Microsoft Azure Site Recovery Unified Setup (VMware-to-Azure) (versione: 9.11.4609.1.)
È consigliabile apprendere i dettagli dei problemi risolti e rivedere i prerequisiti prima di installare questo aggiornamento.
Riepilogo
L'aggiornamento cumulativo 20 per Microsoft Azure Site Recovery Provider si applica a tutti i sistemi in cui è installato Microsoft Azure Site Recovery Service Provider. Questi includono quanto segue:
- Microsoft Azure Site Recovery Provider per System Center Virtual Machine Manager (3.3.x.x)
- Provider Microsoft Azure Site Recovery Hyper-V (4.6.x.x)
- Provider di Azure Site Recovery Microsoft (5.1.x.x)
L'aggiornamento cumulativo 20 per Microsoft Azure Site Recovery Unified Setup (VMware-to-Azure) si applica a tutti i sistemi in cui è installato Microsoft Azure Site Recovery Services Unified Setup versione 9.8.4016.1 o successiva.
Problemi risolti in questo aggiornamento
Dopo l'applicazione di questo aggiornamento, sono stati risolti i seguenti problemi e sono stati inclusi i seguenti miglioramenti:
Configurazione unificata di Microsoft Azure Site Recovery
Problemi risolti
- È stato aggiunto un prerequisito per assicurarsi che gli strumenti VMware siano installati nel server in cui viene installata la configurazione unificata (valido solo per lo scenario "VMware-to-Azure Protection").
Servizio di mobilità
Miglioramenti
- Per le macchine virtuali di Azure, l'utente doveva installare in modo esplicito i certificati radice attendibili nell'archivio. Dopo questo aggiornamento, i certificati radice attendibili necessari vengono installati automaticamente nell'archivio purché nella macchina virtuale siano installati gli aggiornamenti più recenti di Windows.
- Supporto per Debian 7 e Debian 8.
- Supporto per Red Hat Enterprise Linux 6.9.
- Supporto per Cent OS 6.9.
- Gli utenti spesso riscontravano problemi di replica che non rispondevano a causa di più voci degli ID delle macchine virtuali nel server di configurazione. In questa versione vengono apportati miglioramenti per evitare problemi di mancata risposta della replica che si verificano a causa di ID host non aggiornati sul server protetto.
- In precedenza gli utenti dovevano citare l'indirizzo IP del server nel file /etc/host per proteggere il server Linux. In questa versione, il requisito di citare l'indirizzo IP host nel file host è stato rimosso.
Per un elenco dei sistemi operativi supportati da ASR per le macchine virtuali VMware e i server fisici, vedere Supporto per le versioni del sistema operativo delle macchine replicate.
Per un elenco dei sistemi operativi supportati da ASR per il ripristino di emergenza di Azure macchine virtuali, vedere Azure Site Recovery matrice di supporto per la replica da Azure a Azure.
Problemi risolti
- L'agente di macchine virtuali di Windows Azure viene usato dalle macchine virtuali di Azure per fornire la diagnostica di avvio e abilitare l'installazione delle estensioni delle macchine virtuali di Azure. Dopo questo aggiornamento, i servizi dell'agente di Windows Azure vengono disabilitati mentre la macchina virtuale è in esecuzione in locale. Dopo aver eseguito il failover della macchina virtuale in Azure, è necessario abilitare manualmente questi servizi.
- Miglioramenti nel programma di installazione e negli strumenti di configurazione del servizio Mobility per fornire una migliore resilienza durante la protezione dell'abilitazione.
- Diagnostica e messaggi di errore migliori per gestire situazioni quali condizioni di memoria insufficiente, spazio su disco insufficiente e situazioni di "accesso negato" nel computer di destinazione in cui viene installato il servizio Mobility.
- Logica migliore per evitare che il server di elaborazione abbia una limitazione cumulativa per i server ad alta variazione.
- Un messaggio di errore migliore viene visualizzato quando il cliente rimuove la protezione post del disco.
Microsoft Azure Site Recovery (correzioni sul lato servizio)
Miglioramenti
Per gli scenari "Ripristino di emergenza da Azure ad Azure", la macchina virtuale di origine è stata eliminata quando è stato eseguito "Ri-protezione" dopo il failover. Dopo l'applicazione di questo aggiornamento, la macchina virtuale di origine viene mantenuta intatta. Verrà riutilizzata quando viene eseguito il failover successivo.
Il failover nei dischi gestiti dagli account di archiviazione crittografati viene abilitato dopo l'applicazione di questo aggiornamento. Questo vale per le macchine virtuali che eseguono il failover su dischi gestiti in Azure da ambienti VMware e Hyper-V locali.
Notifiche Email: il verificarsi di un errore di replica può causare una serie di errori ed eventi correlati per le macchine virtuali VMware e i server fisici protetti. Dopo l'applicazione di questo aggiornamento, le notifiche tramite posta elettronica sugli eventi di integrità delle macchine virtuali saranno limitate agli eventi che causano il passaggio dell'integrità della replica da uno stato non critico a uno stato critico. Altri errori ed eventi verranno comunque registrati e visualizzati nel portale. Tuttavia, non attiveranno più un messaggio di posta elettronica. In questo modo si evitano notifiche ridondanti.
Ad esempio, se l'integrità della replica di una macchina virtuale è critica a causa di un errore esistente, un successivo errore di replica critica per la stessa macchina virtuale non causerà più l'invio di una notifica e-mail per il secondo errore. Ciò è dovuto al fatto che l'integrità della replica è già critica prima che si verifichi il secondo errore.
Problemi risolti
- Per alcune sottoscrizioni, l'abilitazione della replica non riusciva a causa del token di autorizzazione mancante.
- Per lo scenario "Azure-to-Azure DR", le macchine virtuali classiche con endpoint con bilanciamento del carico hanno avuto problemi di failover.
Microsoft Azure Site Recovery (correzioni lato portale)
Miglioramenti
- Se la sottoscrizione non è abilitata per creare macchine virtuali nell'area di destinazione selezionata per lo scenario "Da Azure ad Azure DR", un errore impedisce all'utente di creare le macchine virtuali. Il messaggio di errore chiede all'utente di recuperare la quota contattando il supporto tecnico o selezionando un'altra area di destinazione con la quota disponibile per creare la macchina virtuale.
- Le macchine virtuali configurate per il failover in un set di disponibilità ora richiedono che tutte le macchine virtuali nello stesso set di disponibilità utilizzino le dimensioni di macchine virtuali della stessa famiglia.
Problemi risolti
- Per lo scenario "Da Azure ad Azure DR", il terzo passaggio in "Abilitare la replica" occasionalmente non viene caricato.
Aggiornamento dei componenti locali Azure Site Recovery
| Scenario | Procedura |
|---|---|
| Tra aree di Azure |
|
| Tra due siti VMM locali Oppure Tra due siti VMM locali che usano la replica di matrice SAN |
|
| Tra un sito VMM locale e Azure |
|
| Tra un sito Hyper-V locale e Azure |
|
| Tra un sito VMware locale/fisico e Azure |
|
Informazioni sull'aggiornamento
Per risolvere questi problemi, scarica e installa i file seguenti dall'Area download Microsoft:
Scarica l'aggiornamento cumulativo 20 per il provider di Azure Site Recovery Microsoft
Scarica l'aggiornamento cumulativo 20 per l'installazione unificata di Microsoft Azure Site Recovery
Per altre informazioni su come scaricare i file di supporto Microsoft, vedere il seguente articolo della Microsoft Knowledge Base:
119591 Come ottenere file di supporto Microsoft da Servizi online
Microsoft ha analizzato questo file alla ricerca di virus. Microsoft usava il software antivirus più recente disponibile al momento della data di pubblicazione del file. Il file è memorizzato su server con un livello di sicurezza avanzata che impedisce modifiche del file non autorizzate.
Prerequisiti
Per installare l'aggiornamento cumulativo 20 di Microsoft Azure Site Recovery Provider (versione 5.1.1950.0), è necessario che sia installato uno dei dispositivi seguenti:
- Microsoft Azure Hyper-V Gestione ripristino (versione 3.4.486 o successiva)
- Provider Microsoft Azure Site Recovery Hyper-V (versione 4.6.660 o successiva)
- Microsoft Azure Site Recovery Provider (versione 5.1.1000 o successiva)
Per installare l'aggiornamento cumulativo 20 dell'installazione unificata di Microsoft Azure Site Recovery (versione 9.1.4358.1), devi aver installato quanto segue:
- Microsoft Azure Site Recovery Unified Setup (VMware-to-Azure) (versione 9.0.4016.1 o successiva)
Avvertenza È possibile controllare la versione del provider installato nella voce Programmi e funzionalità nel Pannello di controllo.
Informazioni sul riavvio
Non è necessario riavviare il computer dopo aver applicato questo aggiornamento in un server Hyper-V o in un computer in cui è installato System Center Virtual Machine Manager.
Questo aggiornamento arresta e riavvia automaticamente i servizi di System Center Virtual Machine Manager durante il processo di aggiornamento.
Dopo l'applicazione di questo aggiornamento, sarà necessario riavviare il server di configurazione e i server protetti.
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.
Informazioni sulla dichiarazione di non responsabilità di terze parti
I prodotti di terze parti citati in questo articolo sono prodotti da società indipendenti di Microsoft. Microsoft non riconosce alcuna garanzia, implicita o espressa, in relazione alle prestazioni o all'affidabilità di tali prodotti.