Sintomi
Si supponga che si utilizzi una porta di trasmissione SFTP per inviare messaggi e che la proprietà di trasporto "Nome file di destinazione" contenga la macro "%datetime.tz%" o "%time.tz%". Quando un messaggio viene inviato utilizzando questa porta di trasmissione, il messaggio viene sospeso e viene visualizzato il messaggio di errore seguente:
Nota
- Un messaggio inviato all'adapter "SFTP" sulla porta di trasmissione "*****" con URI "sftp://*************/*%datetime.tz%*.*" viene sospeso.
- Dettagli errore: System.NotSupportedException: Il formato del percorso specificato non è supportato.
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Risoluzione
Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per BizTalk Server:
- Aggiornamento cumulativo 2 per BizTalk Server 2020
- Aggiornamento cumulativo 8 per BizTalk Server 2016
Riferimenti
Per informazioni sui Service Pack e sull'elenco degli aggiornamenti cumulativi per BizTalk Server, vedere il seguente articolo della Microsoft Knowledge Base:
2555976 Service Pack ed elenco degli aggiornamenti cumulativi per BizTalk Server
Per ulteriori informazioni sugli aggiornamenti rapidi per BizTalk Server, vedere il seguente articolo della Microsoft Knowledge Base:
2003907 informazioni sul supporto per gli aggiornamenti cumulativi e gli aggiornamenti rapidi di BizTalk