Sintomi
Quando una porta di trasmissione WCF-SQL che utilizza un valore ColumnEncryptionSettings=Enabled chiama una stored procedure che esegue una query in una tabella con una colonna crittografata di tipo "varchar(max)", l'adapter WCF-SQL non legge la colonna crittografata. Viene inoltre generato il seguente messaggio di errore:
Nota
- Un messaggio inviato all'adapter "WCF-SQL" sulla porta di trasmissione "" con URI "mssql://************" viene sospeso.
- Dettagli errore: System.InvalidOperationException: Il recupero dei "dati" della colonna crittografata con CommandBehavior=SequentialAccess non è supportato.
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Risoluzione
Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per BizTalk Server:
- Aggiornamento cumulativo 2 per BizTalk Server 2020
- Aggiornamento cumulativo 8 per BizTalk Server 2016
Riferimenti
Per informazioni sui Service Pack e sull'elenco degli aggiornamenti cumulativi per BizTalk Server, vedere il seguente articolo della Microsoft Knowledge Base:
2555976 Service Pack ed elenco degli aggiornamenti cumulativi per BizTalk Server
Per ulteriori informazioni sugli aggiornamenti rapidi per BizTalk Server, vedere il seguente articolo della Microsoft Knowledge Base:
2003907 informazioni sul supporto per gli aggiornamenti cumulativi e gli aggiornamenti rapidi di BizTalk