KB5003146 - CORREZIONE: non è possibile ricevere messaggi con l'adattatore LogicApp perché la posizione di ricezione viene disabilitata

Si applica a
BizTalk Server 2020 Branch BizTalk Server 2020 Developer BizTalk Server 2020 Enterprise BizTalk Server 2020 Standard

Sintomi

Quando un percorso di ricezione che usa l'adattatore dell'app Logic è abilitato, viene disabilitato con l'errore del registro eventi seguente:

Il motore di messaggistica ha rilevato un errore durante la creazione della scheda di ricezione "LogicApp". L'assembly è: "Microsoft.BizTalk.Adapter.LogicApp.Runtime.LogicAppReceiver, Microsoft.BizTalk.Adapter.LogicApp.Runtime". Si è verificato l'errore perché il componente non implementa l'interfaccia obbligatoria "IBTTransportControl".

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Risoluzione

Questo problema è stato risolto nel seguente aggiornamento cumulativo per BizTalk Server:

Aggiornamento cumulativo 2 per BizTalk Server 2020

Nota Dopo aver applicato questa correzione, i nuovi gestori di ricezione verranno aggiunti come gestore di ricezione isolato. Tutti i gestori di ricezione LogicApp in-process esistenti devono essere eliminati manualmente.

Riferimenti

Per informazioni sui Service Pack e sull'elenco degli aggiornamenti cumulativi per BizTalk Server, vedere il seguente articolo della Microsoft Knowledge Base:

2555976 Service Pack e l'elenco di aggiornamenti cumulativi per BizTalk Server

Per ulteriori informazioni su BizTalk Server aggiornamenti rapidi, vedere il seguente articolo della Microsoft Knowledge Base:

2003097 informazioni sugli aggiornamenti rapidi BizTalk e sul supporto degli aggiornamenti cumulativi