Non è possibile determinare quali campi sono disponibili e quali non sono disponibili quando si apre una finestra di dialogo in Microsoft Dynamics NAV

Microsoft Business Solutions-Navision 4.0 e Microsoft Navision 4.0 fanno ora parte di Microsoft Dynamics NAV 4.0. Tutti i riferimenti a Microsoft Business Solutions-Navision o a Microsoft Navision 4.0 riguardano Microsoft Dynamics NAV.

Questo articolo si applica a Microsoft Dynamics NAV 4.0 per tutte le aree geografiche.

Sintomi

Quando si apre una finestra di dialogo in Microsoft Dynamics NAV, non è possibile determinare quali campi sono disponibili e quali campi non sono disponibili perché tutti i campi sembrano disponibili. Questo problema si verifica se si verificano le condizioni seguenti:

  • Si usa Microsoft Dynamics NAV in un computer basato su Windows Vista.
  • La combinazione di colori Di Windows Aero è abilitata nel computer.

Ad esempio, questo problema si verifica quando si apre la finestra di dialogo Scheda cliente in Microsoft Dynamics NAV. In questo caso, il campo Saldo e il campo Limite credito hanno lo stesso colore. Tuttavia, il campo Saldo dovrebbe essere visualizzato in grigio perché non è disponibile.

Causa

Questo problema si verifica perché Microsoft Dynamics NAV utilizza controlli di Windows con un aspetto diverso quando il computer esegue Windows Vista.

Risoluzione

Informazioni sull'aggiornamento rapido

È ora disponibile un hotfix supportato da Microsoft. L'hotfix corregge il problema descritto in questo articolo. Applicare l'aggiornamento rapido solo ai sistemi che presentano questo problema specifico.

Per risolvere immediatamente il problema, contattare il supporto tecnico per Microsoft Dynamics e i prodotti correlati per ottenere l'aggiornamento rapido. È possibile accedere al sito di Microsoft Dynamics e creare una nuova richiesta di supporto. A tale scopo, visitare il seguente sito Web Microsoft:

https://mbs.microsoft.com/support/newstart.aspx È anche possibile contattare il supporto tecnico per Microsoft Dynamics e i prodotti correlati telefonicamente al numero (888) 477-7877.

Nota In casi speciali, gli addebiti normalmente sostenuti per le chiamate al supporto tecnico possono essere annullati se un professionista del supporto tecnico per Microsoft Dynamics e i prodotti correlati determinano che un aggiornamento specifico risolverà il problema. I soliti costi di supporto si applicano a eventuali altre domande e problemi di supporto che non sono idonei per l'aggiornamento specifico in questione.

Come ottenere l'aggiornamento rapido o i file di aggiornamento di Microsoft Dynamics NAV

Dopo aver richiesto un hotfix di Microsoft Dynamics NAV o un file di aggiornamento al supporto tecnico per Microsoft Dynamics, verrà inviato un collegamento ipertestuale in un messaggio di posta elettronica.

Il messaggio di posta elettronica conterrà un collegamento ipertestuale e una password. È possibile utilizzare il collegamento ipertestuale per scaricare l'hotfix Microsoft Dynamics NAV o i file di aggiornamento. Quando si fa clic sul collegamento ipertestuale, viene visualizzata la finestra di dialogo Download file - Avviso di sicurezza . Viene quindi richiesto di eseguire, salvare o annullare il download.

Se si fa clic su Esegui, i file avviano il download e il processo di estrazione. È necessario specificare una cartella per i nuovi file e quindi specificare la password.

Se si fa clic su Salva, è necessario specificare un percorso per il salvataggio del file compresso. Quando si apre il file salvato, viene chiesto di specificare un percorso per i file. È quindi necessario fornire la password specificata nell'e-mail.

Se si fa clic su Annulla, il processo di download si interrompe.

Come installare un hotfix o un file di aggiornamento di Microsoft Dynamics NAV

Gli aggiornamenti rapidi e gli aggiornamenti della piattaforma Microsoft Dynamics NAV vengono resi disponibili come file singoli. Per installare un hotfix di Microsoft Dynamics NAV o un aggiornamento, è necessario sostituire i file di installazione di Microsoft Dynamics NAV esistenti con l'hotfix o i file di aggiornamento. A tale scopo, attenersi alla seguente procedura.

Microsoft Dynamics NAV 4.0 SP3

Passaggio 1: Sostituire il file di installazione del client Microsoft Dynamics NAV

Nell'installazione del client Microsoft Dynamics NAV sostituire i file seguenti utilizzando l'hotfix o il file di aggiornamento.

Nome file Versione del file Dimensioni del file Data Ora Piattaforma
Dbm.dll 4.0.3.25206 345,208 13 settembre 2007 20:18 x86
Fin.exe 4.0.3.25206 8,119,416 13 settembre 2007 20:18 x86
Fin.exe.manifest Non applicabile 711 11 settembre 2007 21:13 Non applicabile
Finhlink.exe 4.0.3.25206 119,928 13 settembre 2007 20:17 x86
Finsql.exe 4.0.3.25206 8,168,568 13 settembre 2007 20:18 x86
Finsql.exe.manifest Non applicabile 714 14 dicembre 2006 16:41 Non applicabile
Nc_netb.dll 4.0.3.25206 78,968 13 settembre 2007 20:17 x86
Nc_tcp.dll 4.0.3.25206 83,064 13 settembre 2007 20:17 x86
Nc_tcps.dll 4.0.3.25206 91,256 13 settembre 2007 20:17 x86

Per sostituire i file di Microsoft Dynamics NAV esistenti, attenersi alla seguente procedura:

  1. Chiudere il client Microsoft Dynamics NAV.

  2. Individuare la directory di installazione del client Microsoft Dynamics NAV.

    Nota In genere, il client Microsoft Dynamics NAV viene installato nella seguente directory:
    C:\Program Files\Microsoft Business Solutions-Navision\Client\

  3. Copiare i file scaricati.

  4. Incollare i file scaricati nella directory di installazione del client Microsoft Dynamics NAV.

  5. Nel
    Finestra di dialogo Conferma sostituzione file, fare clic su per sovrascrivere i file nella directory di installazione.

Microsoft Dynamics NAV 2009

Passaggio 1: Sostituire i file di installazione di Microsoft Dynamics NAV Classic Client

Nell'installazione di Microsoft Dynamics NAV Classic Client sostituire i file seguenti utilizzando l'hotfix o il file di aggiornamento.

Nome file Versione del file Dimensioni del file Data Ora Piattaforma
Dbm.dll 6.0.29415.0 444,232 1-luglio-2009 9:19 x86
Fin.exe 6.0.29415.0 12,244,792 1-luglio-2009 9:19 x86
Finhlink.exe 6.0.29415.0 452,432 1-luglio-2009 9:19 x86
Finsql.exe 6.0.29415.0 12,330,832 1-luglio-2009 9:19 x86
Nc_netb.dll 6.0.29415.0 108,352 1-luglio-2009 9:19 x86
Nc_tcp.dll 6.0.29415.0 108,368 1-luglio-2009 9:19 x86
Nc_tcps.dll 6.0.29415.0 153,408 1-luglio-2009 9:19 x86
Ndbcs.dll 6.0.29415.0 1,333,072 1-luglio-2009 9:19 x86
Slave.exe 6.0.29415.0 161,616 1-luglio-2009 9:19 x86

Per sostituire i file di Microsoft Dynamics NAV esistenti, attenersi alla seguente procedura:

  1. Chiudere il client Microsoft Dynamics NAV.

  2. Individuare la directory di installazione di Microsoft Dynamics NAV Classic Client.

    Nota In genere, il client Microsoft Dynamics NAV Classic è installato nella seguente directory:
    C:\Program Files\Microsoft Dynamics NAV\60\CSIDE Client\

  3. Copiare i file scaricati.

  4. Incollare i file scaricati nella directory di installazione di Microsoft Dynamics NAV Classic Client.

  5. Nel
    Finestra di dialogo Conferma sostituzione file, fare clic su per sovrascrivere i file nella directory di installazione.

Passaggio 2: Sostituire i file di installazione di Microsoft Dynamics NAV RoleTailored Client

Nell'installazione di Microsoft Dynamics NAV RoleTailored Client sostituire i file seguenti utilizzando l'hotfix o il file di aggiornamento.

Nome file Versione del file Dimensioni del file Data Ora Piattaforma
Dundaswinchart.dll 5.0.0.1692 2,733,904 1-lug-2009 9:19 x86
Microsoft.dynamics.framework.patterns.dll 1.2.10579.173 71,648 30 giugno 2009 7:21 x86
Microsoft.dynamics.framework.ui.dll 1.2.10579.173 654,280 30 giugno 2009 7:21 x86
Microsoft.dynamics.framework.ui.mapping.dll 1.2.10579.173 101,336 30 giugno 2009 7:21 x86
Microsoft.dynamics.framework.ui.navigation.dll 1.2.10579.173 22,496 30 giugno 2009 7:21 x86
Microsoft.dynamics.framework.ui.ux2006.dll 1.2.10579.173 93,064 1-lug-2009 9:08 x86
Microsoft.dynamics.framework.ui.ux2006.winforms.dll 1.2.10579.173 39,840 1-lug-2009 9:08 x86
Microsoft.dynamics.framework.ui.windows.dll 1.2.10579.173 84,952 30 giugno 2009 7:21 x86
Microsoft.dynamics.framework.ui.winforms.controls.dll 1.2.10579.173 2,067,440 30 giugno 2009 7:21 x86
Microsoft.dynamics.framework.ui.winforms.dll 1.2.10579.173 633,824 30 giugno 2009 7:21 x86
Microsoft.dynamics.nav.client.builder.dll 1.2.10579.173 166,792 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.client.exe 6.0.29415.0 142,200 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.client.interop.communicator.dll 6.0.29415.0 76,704 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.client.serviceconnection.dll 6.0.29415.0 76,704 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.client.ui.dll 6.0.29415.0 428,920 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.client.winforms.dll 6.0.29415.0 277,384 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.client.winforms.tlb 6.0.29415.0 2,652 1-lug-2009 4:37 Non applicabile
Microsoft.dynamics.nav.language.dll Non applicabile 1,866,616 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.types.dll 6.0.29415.0 383,856 1-lug-2009 9:08 x86
Microsoft.office.interop.outlook.dll 10.0.4504.0 396,152 1-lug-2009 9:08 x86

Per sostituire i file esistenti, procedere come segue:

  1. Chiudere il client personalizzato con ruoli di Microsoft Dynamics NAV.
  2. Individuare la directory di installazione di Microsoft Dynamics NAV RoleTailored Client. In genere, il client Personalizzato per i ruoli di Microsoft Dynamics NAV viene installato nella seguente directory:
    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client
  3. Copiare i file scaricati.
  4. Incollare i file scaricati nella directory di installazione di Microsoft Dynamics NAV RoleTailored Client.
  5. Quando richiesto, fare clic su per sovrascrivere i file nella directory di installazione.

Passaggio 3: Sostituire i file di installazione di Microsoft Dynamics NAV Server

Nell'installazione di Microsoft Dynamics NAV Server sostituire i file seguenti utilizzando l'hotfix o il file di aggiornamento.

Nome file Versione del file Dimensioni del file Data Ora Piattaforma
Httpcfg.exe 5.2.3790.0 22,352 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.language.dll 6.0.29415.0 1,865,600 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.ncl.dll 6.0.29415.0 489,336 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.server.exe 6.0.29415.0 137,088 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.server.exe.config Non applicabile 211 17 giugno 2009 3:29 Non applicabile
Microsoft.dynamics.nav.service.dll 6.0.29415.0 120,704 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.service.runtime.dll 6.0.29415.0 63,376 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.service.webservices.dll 6.0.29415.0 128,920 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.types.dll 6.0.29415.0 382,840 1-lug-2009 9:08 x86
Microsoft.dynamics.nav.watson.dll 6.0.29415.0 38,784 1-lug-2009 9:08 x86
Nclcsrt.etx Non applicabile 87,279 1-lug-2009 12:52 Non applicabile
Nclcsrt.stx Non applicabile 81,083 1-lug-2009 12:52 Non applicabile
Nclcsrts.dll Non applicabile 1,394,512 1-lug-2009 9:19 x86
Ndbcs.dll 6.0.29415.0 1,333,072 1-lug-2009 9:19 x86

Per sostituire i file, procedere come segue:

  1. Arrestare il servizio server Microsoft Dynamics NAV.

  2. Individuare la directory di installazione del servizio server Microsoft Dynamics NAV.

    Nota In genere, il servizio server Microsoft Dynamics NAV viene installato nella seguente directory:

    C:\programmi\Microsoft Dynamics NAV\60\Service

  3. Copiare i file scaricati.

  4. Incollare i file scaricati nella directory di installazione del servizio server Microsoft Dynamics NAV.

  5. Fare clic su per sovrascrivere i file nella directory.

  6. Avviare il servizio server Microsoft Dynamics NAV.

Passaggio 4: Sostituire i file di Files comuni

Nella cartella Files comune sostituire i file seguenti.

Nome file Versione del file Dimensioni del file Data Ora Piattaforma
Customization.xml Non applicabile 1,115 17 giugno 2009 3:24 Non applicabile
File Msoutl.olb 11.0.5510.0 200,248 17 giugno 2009 3:24 Non applicabile

Per sostituire i file esistenti, procedere come segue:

  1. Individuare la directory di Files comuni:

    C:\Program Files\Common Files\Microsoft Dynamics NAV\OLSync

  2. Copiare i file scaricati.

  3. Incollare i file scaricati nella directory Common Files.

  4. Quando richiesto, fare clic su per sovrascrivere i file nella directory di installazione.

Passaggio 5: Sostituire i file di Windows\System32

Nella cartella Windows\System32 sostituire i file seguenti.

Nome file Versione del file Dimensioni del file Data Ora Piattaforma
Cdo.dll 6.5.7940.0 775,480 1-lug-2009 9:19 x86
Gapi32.dll 6.5.7940.0 71,488 1-lug-2009 9:19 x86

Per sostituire i file esistenti, procedere come segue:

  1. Individuare la directory Windows\System32:

    C:\Windows\System32

  2. Copiare i file scaricati.

  3. Incollare i file scaricati nella directory Common Files.

  4. Quando richiesto, fare clic su per sovrascrivere i file nella directory di installazione.

Prerequisiti

Per applicare questo hotfix, è necessario che sia installato uno dei prodotti seguenti:

  • Microsoft Dynamics NAV 4.0 SP3 con aggiornamento rapido KB 940718

  • Microsoft Dynamics NAV 2009

Informazioni sulla rimozione

Non è possibile rimuovere questo hotfix.

Richiesta di riavvio

Se viene richiesto di riavviare il computer, è necessario riavviare il computer dopo aver applicato questo hotfix.

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Altre informazioni

Per altre informazioni sulla terminologia di aggiornamento software, fare clic sul numero dell'articolo seguente per visualizzare l'articolo della Microsoft Knowledge Base:

824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft