Sintomi
Dopo aver completato o annullato uno spedizioniere, il valore nella casella Stato non viene aggiornato a Chiuso in Gestione ordini in Microsoft Dynamics SL.
Nota La casella Stato viene visualizzata nella scheda Altre informazioni della schermata Corrieri (40.110.00). Inoltre, la schermata Shipper Update Log Viewer (40.460.00) non include una voce per l'ID corriere.
Causa
Causa 1
L'impostazione Ritardo aggiornamento spedizioniere non è corretta. Vedi Risoluzione 1.
Causa 2
L'impostazione del tempo di sospensione per Process Manager è troppo piccola. Vedi Risoluzione 2
Causa 3
Il passaggio Aggiorna spedizioniere nella scheda Passaggi della schermata Tipi di ordine (40.200.00) non è configurato correttamente. Vedi Risoluzione 3.
Causa 4
Il tipo di ordine è stato modificato nella scheda Passaggi della schermata Tipi di ordine (40.200.00) prima della chiusura degli spedizionieri esistenti. Vedi Risoluzione 4.
Causa 5
Sono state aggiunte personalizzazioni alla schermata Shippers (40.110.00) che ha interrotto l'elaborazione dei record dello spedizioniere. Vedi Risoluzione 5.
Causa 6
Qualsiasi causa diversa dalla causa da 1 a 5. In questo caso, questo problema si verifica indipendentemente dal tipo di ordine. Vedi Risoluzione 6 o Risoluzione 7.
Risoluzione
Soluzione 1
Verifica che l'impostazione per posticipare l'aggiornamento dello spedizioniere non sia troppo grande. A questo scopo, procedere come segue:
Nel menu Modulo fare clic su Gestione ordini.
Nel riquadro Gestione ordini fare clic su Imposta gestione ordini in Imposta.
Nella scheda Altro verificare che il valore nella casella Ritardo aggiornamento spedizioniere (minuti) non sia troppo grande.
Nota Se il valore Delay Shipper Update (minutes) è impostato su 30, lo spedizioniere non si chiuderà fino a 30 minuti dopo il completamento del record dello spedizioniere.
Soluzione 2
Aumentare il tempo di sospensione per il processo di Process Manager. A questo scopo, procedere come segue:
Nel menu Modulo fare clic su Gestione ordini.
Nel riquadro Gestione ordini fare clic su Imposta gestione ordini in Imposta.
Nella scheda Altro digitare 15 nella casella Tempo di sospensione (secondi) di Process Manager se il valore nella casella è minore di 15.
Risoluzione 3
Correggere lo stato del passaggio nel tipo di ordine. A questo scopo, procedere come segue:
Nell'elenco Moduli fare clic su Gestione ordini.
Nel riquadro Gestione ordini fare clic su Tipi di ordine in Manutenzione.
Nella casella Tipo di ordine digitare l'ID del tipo di ordine da modificare.
Nella scheda Passaggi fare clic su Obbligatorio nel passaggio Stato per l'aggiornamento dello spedizioniere.
Fare clic su Salva. Chiudere quindi la schermata Tipi di ordine (40.200.00).
Risoluzione 4
Annullare gli spedizionieri e i relativi ordini cliente. A questo scopo, procedere come segue:
Nell'elenco Moduli fare clic su Gestione ordini.
Nel riquadro Gestione ordini fare clic su Conferma spedizione in Input.
Nella casella ID corriere digitare l'ID del corriere da annullare.
Fare clic per selezionare le caselle di controllo seguenti:
- Annulla spedizioniere
- Annulla ordine
Fare clic su Fine. Quindi, chiudi la schermata di conferma della spedizione (40.117.00).
Risoluzione 5
Rimuovere le personalizzazioni per la schermata Shippers (40.110.00). A questo scopo, procedere come segue:
Chiudi tutte le schermate tranne la schermata Shippers(40.110.00).
Scegliere Modalità di personalizzazione dal menu Personalizza.
Nel menu Personalizza fare clic su Rimuovi modifiche per lo schermo.
Fare clic su Sì e quindi su OK.
Chiudere la schermata Shippers (40.110.00). Quindi apri lo schermo.
Risoluzione 6
Modificare l'ordine degli spedizionieri impostando un ordine riconosciuto da Process Manager. A tale scopo, attenersi alla seguente procedura.
Nota Prima di seguire le istruzioni in questa procedura, assicurarsi di avere una copia di backup completa del database che è possibile ripristinare in caso di problemi.
Nella schermata Process Manager (40.400.00) fare clic su Interrompi.
Usando Microsoft SQL Query Analyzer o Microsoft SQL Server Management Studio, eseguire l'istruzione appropriata sul database dell'applicazione.
-
Microsoft SQL Server 7.0
Nota
SELECT "execADG_Release_For_Update '" + rtrim(CpnyID) + "', '', '" +rtrim(ShipperID) + "'" da SOSHIPHEADER dove NextFunctionID ="4043000" e NextFunctionClass = "0200"
Microsoft SQL Server 2000 o Microsoft SQL Server 2005 o Microsoft SQL Server 2008
Nota
SET QUOTED_IDENTIFIEROFF SELECT "exec ADG_Release_For_Update '" + rtrim(CpnyID) + "','' , '" + rtrim(ShipperID) + "'" da SOSHIPHEADER doveNextFunctionID = "4043000" e NextFunctionClass = "0200"
Copiare i risultati dell'istruzione in una nuova finestra. Escludere le intestazioni di colonna o le righe del conteggio righe. Eseguire quindi la nuova istruzione per accodare nuovamente gli shippers elencati.
Nota L'istruzione seguente è un esempio dei risultati da copiare.
Nota
exec ADG_Release_For_Update '0060', ''', 'S0009868'
Nella schermata Process Manager (40.400.00) fare clic su Start.
Risoluzione 7
Annulla lo spedizioniere. A questo scopo, procedere come segue:
Nell'elenco Moduli fare clic su Gestione ordini.
Nel riquadro Gestione ordini fare clic su Corrieri in Input.
Nella scheda Altre informazioni fare clic per selezionare la casella di controllo Annullato e quindi fare clic su Fine.