KB2682488 - FIX: Operazione di backup non riuscita in un database SQL Server dopo aver abilitato il rilevamento delle modifiche

Si applica a
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Microsoft distribuisce le correzioni di Microsoft SQL Server 2008 o Microsoft SQL Server 2008 R2 come un unico file scaricabile. Poiché le correzioni sono cumulative, ogni nuova versione contiene tutte le correzioni rapide e di sicurezza incluse nella versione precedente della correzione di SQL Server 2008 o SQL Server 2008 R2.

Sintomi

Dopo aver abilitato il rilevamento delle modifiche in Microsoft SQL Server 2008, Microsoft SQL Server 2008 R2, Microsoft SQL Server 2012 o in database di SQL Server 2014, le operazioni di backup hanno esito negativo e un messaggio di errore simile al seguente viene registrato nel file di log degli errori di SQL Server:

Nota

<Data><ora><spid> Errore: 2601, gravità: 14, stato: 1.
<Data><ora><spid> Non è possibile inserire una riga chiave duplicata nell'oggetto 'sys.syscommittab' con indice univoco '<Index Name>'.
<Data><e ora><spid> Errore: 3999, gravità: 17, stato: 1.
<Data><e ora><spid> Impossibile scaricare la tabella di commit su disco nell'ID> database dbid <a causa dell'errore 2601. Per altre informazioni, vedere il log degli errori.

Inoltre, viene visualizzato un codice di errore 2601 quando SQL Server 2008 tenta di eseguire un'operazione di checkpoint sul database.

Nota: per una panoramica dei checkpoint del database di SQL Server, visitare il seguente sito Web MSDN:

Punti di controllo del database (SQL Server)

Risoluzione

Informazioni sul Service Pack per SQL Server 2008 R2

Per risolvere questo problema, ottenere il service pack più recente per SQL Server 2008 R2. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

2527041 Come ottenere il service pack più recente per SQL Server 2008 R2

Informazioni sull'aggiornamento cumulativo

Il problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente di SQL Server:

Consiglio: installare l'aggiornamento cumulativo più recente per SQL Server

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. È consigliabile scaricare e installare gli aggiornamenti cumulativi più recenti per SQL Server:

      

        
      

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Riferimenti

Per ulteriori informazioni sul modello di servizio incrementale per SQL Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

935897 un modello di manutenzione incrementale è disponibile presso il team SQL Server per fornire correzioni rapide per i problemi segnalatiPer ulteriori informazioni sullo schema di denominazione per gli aggiornamenti SQL Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

822499 schema di denominazione per i pacchetti di aggiornamento software Microsoft SQL Server Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Altre informazioni

Per risolvere un problema correlato in SQL Server, vedere l'articolo della Knowledge Base seguente:

Righe chiave duplicate dalla tabella sys.syscommittab in SQL Server