Sintomi
Quando si verifica questo problema, l'operazione di backup ha esito negativo e viene visualizzato un messaggio di errore simile al seguente:
Nota
[SSMBackup2WAAdminXevent] Nome database = <database_name>, ID database = <database_id>, Stage = <stage_name>, Codice di errore = 3002, Messaggio di errore = Impossibile eseguire il BACKUP o il RIPRISTINO di uno snapshot del database. [SQLSTATE 42000]IL DATABASE DI BACKUP viene terminato in modo anomalo. [SQLSTATE 42000], Informazioni aggiuntive = Riprovare il backup.
Causa
Questo problema si verifica perché il backup di uno snapshot del database non è supportato in SQL Server 2014 SP1 e SP2.
Risoluzione
Informazioni sul Service Pack
Questo problema è stato risolto in SQL Server 2016 Service Pack 1 (SP1). Vedere le versioni build di SQL Server 2016.
Informazioni sull'aggiornamento cumulativo
Il problema è stato risolto nell'aggiornamento cumulativo seguente di SQL Server:
- Aggiornamento cumulativo 3 per SQL Server 2016
- Aggiornamento cumulativo 1 per SQL Server 2014 SP2
- Aggiornamento cumulativo 7 per SQL Server 2014 SP1
Consiglio: installare l'aggiornamento cumulativo più recente per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. È consigliabile scaricare e installare gli aggiornamenti cumulativi più recenti per SQL Server:
- Aggiornamento cumulativo più recente per SQL Server 2016
- Aggiornamento cumulativo più recente per SQL Server 2014 (SP1/SP2)
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".