KB4045814 - FIX: Errore "Messaggio 611" quando si usa BULK INSERT o INSERT SELECT per inserire dati in un indice columnstore cluster

Si applica a
SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2017 Enterprise on Windows

Sintomi

Si consideri lo scenario seguente:

  • Si crea un indice columnstore cluster in una tabella partizionata.
  • La lunghezza massima delle colonne della tabella è maggiore del limite di 8.060 byte per le righe per le tabelle se sono presenti colonne di lunghezza variabile.
  • Usare l'istruzione BULK INSERT o INSERT SELECT per inserire dati nell'indice columnstore cluster.

In questo caso, viene visualizzato un messaggio di errore simile al seguente:

Nota

Messaggio 611, livello 16, stato 0
Impossibile inserire o aggiornare una riga perché la dimensione totale delle colonne variabili, incluso il sovraccarico, è di 1978 byte in più rispetto al limite.

Risoluzione

Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:

Aggiornamento cumulativo 2 per SQL Server 2017

Aggiornamento cumulativo 8 per SQL Server 2014 Service Pack 2

Informazioni sugli aggiornamenti cumulativi per SQL Server

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni a caldo e di sicurezza presenti nella build precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

Aggiornamento cumulativo più recente per SQL Server 2017

Aggiornamenti cumulativi più recenti per SQL Server 2014.

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.