KB4515772 - FIX: il log delle transazioni non viene troncato in un gruppo di disponibilità a nodo singolo in SQL Server

Si applica a
SQL Server 2016 Service Pack 2 SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 Developer on Windows SQL Server 2017 Enterprise Core on Windows SQL Server 2017 Enterprise on Windows SQL Server 2017 Standard on Windows SQL Server 2019 on Windows SQL Server 2016 SQL Server 2016 Service Pack 3 - duplicate (do not use)

Sintomi

Si supponga di avere un gruppo di disponibilità Always On che include solo una replica primaria, non repliche secondarie. Nel corso del tempo, è possibile che venga visualizzato il messaggio di errore seguente:

Errore 9002. Il log delle transazioni per il database è pieno a causa di 'AVAILABILITY_REPLICA'.

Quando si esegue un backup del log delle transazioni, l'errore non viene risolto perché il log non viene troncato e usa tutto lo spazio disponibile.

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Risoluzione

Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:

Informazioni sugli aggiornamenti cumulativi per SQL Server:

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

Informazioni sul Service Pack per SQL Server 2016

Questo problema è stato risolto nel seguente service pack per SQL Server:

Informazioni sui Service Pack per SQL Server:

I service pack sono cumulativi. Ogni nuovo service pack contiene tutte le correzioni presenti nei service pack precedenti, nonché le eventuali nuove correzioni. È consigliabile applicare il service pack più recente e l'aggiornamento cumulativo più recente per il service pack specificato. Non è necessario installare un Service Pack precedente prima di installare il Service Pack più recente. Utilizzare la tabella 1 nell'articolo seguente per ulteriori informazioni sul service pack più recente e sull'aggiornamento cumulativo più recente.

Determinare la versione, l'edizione e il livello di aggiornamento di SQL Server e dei relativi componenti

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.