KB3132058 - FIX: si verifica un errore quando si tenta di eliminare o eliminare filegroup o schemi di partizione e funzioni in SQL Server

Si applica a
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Express SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Express - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Web - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Sintomi

È possibile creare un indice full-text che utilizza un catalogo full-text in Microsoft SQL Server. Se il catalogo è molto grande, SQL Server potrebbe creare alcuni schemi di partizione e funzioni. Questi vengono salvati nei filegroup. Questo comportamento è previsto. Tuttavia, dopo aver eliminato l'indice full-text e il catalogo, tali schemi di partizione e funzioni non vengono rimossi dai filegroup. Inoltre, quando si tenta di eliminare i filegroup che contengono gli schemi di partizione e le funzioni, si riceve un messaggio di errore simile al seguente:

Nota

Messaggio 5042, livello 16, stato 12

Il filegroup 'filegroup_name' non può essere rimosso perché non è vuoto.

        
Se si tenta di eliminare gli schemi di partizione e le funzioni, vengono visualizzati messaggi di errore simili ai seguenti:

Nota

Messaggio 15151, Livello 16, Stato 1

Impossibile eliminare lo schema di partizione 'scheme_name', perché non esiste o non si dispone dell'autorizzazione.

Messaggio 15151, Livello 16, Stato 1

Impossibile eliminare la funzione di partizione 'function_name', perché non esiste o non si dispone dell'autorizzazione.

      

Risoluzione

Questo problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente per SQL Server:

      

Consiglio: installare l'aggiornamento cumulativo più recente per SQL Server

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide a caldo e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

      

Nota: È possibile trovare informazioni sulle build più recenti di SQL Server da Dove trovare informazioni sulle build più recenti di SQL Server.

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.