KB3212318 - FIX: Non è possibile impostare un database sul contenimento parziale se SQL Server rilevamento delle modifiche è stato abilitato in tale database

Si applica a
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1

Sintomi

Si consideri lo scenario seguente:

  • Eseguire almeno un inserimento, un aggiornamento o un'eliminazione in una tabella in cui è abilitato il rilevamento delle modifiche.
  • È possibile disabilitare tutti i rilevamento delle modifiche all'interno del database.

In questo scenario, anche dopo aver disabilitato il rilevamento delle modifiche, quando si prova a impostare il database sul modello di database parzialmente indipendente, è possibile che venga visualizzato un messaggio di errore simile al seguente:

Nota

  • Messaggio 1205, livello 13, stato 18, procedura sp_flush_commit_table, numero di riga
  • La transazione (ID processo 63) è stata bloccata sulle risorse di blocco con un altro processo ed è stata scelta come vittima del deadlock. Eseguire nuovamente la transazione.
  • Messaggio 3999, livello 17, stato 1, numero di riga
  • Impossibile scaricare la tabella di commit su disco in dbid 13 a causa dell'errore 1205. Per altre informazioni, vedere il log degli errori.

Risoluzione

Il problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:

Aggiornamento cumulativo 5 per SQL Server 2016 RTM

Aggiornamento cumulativo 2 per SQL Server 2016 SP1

Aggiornamento cumulativo 4 per SQL Server 2014 Service Pack 2

Informazioni sugli aggiornamenti cumulativi per SQL Server:

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

Aggiornamento cumulativo più recente per SQL Server 2016

Aggiornamento cumulativo più recente per SQL Server 2014

StatoMicrosoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

RiferimentiInformazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.