KB4014738 - CORREZIONE: si verifica un errore quando si abbandona un abbonamento usando un account non sysadmin in SQL Server

Si applica a
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Enterprise Core SQL Server 2012 Standard SQL Server 2012 Service Pack 3 SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Service Pack 2 - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1

Sintomi

Quando si abbandona una sottoscrizione usando un account che non è membro del ruolo predefinito del server sysadmin di SQL Server in Microsoft SQL Server, anche se la sottoscrizione viene eliminata correttamente, è possibile che venga visualizzato un messaggio di errore simile al seguente:

Nota

  • Il sottoscrittore è stato eliminato.
  • Messaggio 0, livello 11, stato 0, riga LineNumber
  • Si è verificato un errore grave nel comando corrente.  I risultati, se presenti, devono essere scartati

Risoluzione

Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:

Aggiornamento cumulativo 6 per SQL Server 2016 RTM

Aggiornamento cumulativo 3 per SQL Server 2016 SP1

Aggiornamento cumulativo 5 per SQL Server 2014 SP2

Aggiornamento cumulativo 12 per SQL Server 2014 SP1

Aggiornamento cumulativo 8 per SQL Server 2012 SP3

Informazioni sugli aggiornamenti cumulativi per SQL Server

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

Aggiornamento cumulativo più recente per SQL Server 2016

Aggiornamento cumulativo più recente per SQL Server 2014

Aggiornamento cumulativo più recente per SQL Server 2012 SP3

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.