Riepilogo
Quando si avvia un'applicazione Desktop Bridge (ad esempio, un'applicazione desktop confezionata come app di Windows) in un server che esegue Microsoft SQL Server, l'applicazione non viene avviata e viene visualizzato il seguente messaggio di errore:
Nota
L'area dati passata a una chiamata al sistema è troppo piccola.
Causa
Questo problema si verifica a causa di errori di comunicazione tra due driver di filtro, in particolare WCNFS (il Desktop Bridge) e il driver RsFxXXXX.sys (SQL Server driver di sistema FILESTREAM). Il driver di sistema RsFx non rispetta in modo appropriato i flag passati dal driver WCNFS. Ciò causa errori di avvio di qualsiasi applicazione Desktop Bridge.
Altre informazioni
Questo miglioramento è incluso nei seguenti aggiornamenti cumulativi per SQL Server:
Aggiornamento cumulativo 8 per SQL Server 2016 SP1
Aggiornamento cumulativo 3 per SQL Server 2017
Aggiornamento cumulativo 11 per SQL Server 2014 SP2
Informazioni sugli aggiornamenti cumulativi per SQL Server:
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
Aggiornamento cumulativo più recente per SQL Server 2016
Aggiornamento cumulativo più recente per SQL Server 2014
Aggiornamento cumulativo più recente per SQL Server 2017
Altre informazioni
Questo miglioramento è incluso nel seguente aggiornamento rapido su richiesta per SQL Server:
Aggiornamento hotfix su richiesta per SQL Server 2012 SP4
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.
Per altre informazioni su Desktop Bridge e sulle soluzioni alternative per questo problema, vedere questo articolo del blog del team Tiger di MSSQL.