Sintomi
Quando si esegue il backup dei database per Azure BLOB di pagina usando istruzioni BackuptoURL, è possibile che venga visualizzato un messaggio di errore simile al seguente:
Data e ora: DateTime
Comando: BACKUP LOG [SAMPLEDB] TO URL = N'UrlPath' WITH CHECKSUM, NO_COMPRESSION, CREDENTIAL = N'CredentialName'
Msg 3271, Livello 16, Stato 1, ServerName, LineNumber
Si è verificato un errore I/O non recuperabile nel file FilePath Backup to URL ha ricevuto un'eccezione dall'endpoint remoto. Messaggio di eccezione: il server remoto ha restituito un errore: (409) Conflitto.
Msg 3013, Level 16, State 1, ServerName, LineNumber
BACKUP LOG sta terminando in modo anomalo.
Risultato: Non riuscito
Durata: DurationTime
Data e ora: DateTime
Nota Il problema riguarda le versioni di Microsoft SQL Server2014, 2016 e 2017. Quando la correzione diventa disponibile per queste versioni, questo KB verrà aggiornato con le informazioni pertinenti.
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Risoluzione
Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:
- Aggiornamento cumulativo 8 per SQL Server 2016 SP2
- Aggiornamento cumulativo 4 per SQL Server 2014 SP3
Informazioni sugli aggiornamenti cumulativi per SQL Server:
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutti gli aggiornamenti rapidi e tutte le correzioni per la sicurezza inclusi nell'aggiornamento cumulativo precedente. Scopri gli aggiornamenti cumulativi più recenti per SQL Server:
- Ultimo aggiornamento cumulativo per SQL Server 2016
- Ultimo aggiornamento cumulativo per SQL Server 2014
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.