Sintomi
Si supponga di avere un database di Microsoft SQL Server 2016 o 2017 con una FileTable. Quando si tenta di montare la condivisione FILESTREAM di SQL Server (o una sottodirectory) da Linux utilizzando SMB 3.x, si nota che il montaggio non riesce e restituisce il seguente messaggio di errore:
Messaggio di errore da Linux:
* [Nome utente ~]$ sudo mount -t cifs -o vers=3.0,sec=ntlmssp,username=Username,domain=DomainName sql_machine_name/filestream_share /mnt/mount_dir
Password [sudo] per il nome utente:
Password per NomeUtente@//sql_machine_name/filestream_share: ********
errore di montaggio(22): argomento non valido
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Risoluzione
Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:
Informazioni sugli aggiornamenti cumulativi per SQL Server:
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.