KB4580915 - FIX: SQL Server registro degli errori riceve diversi messaggi di abilitazione o disabilitazione di ADR anche quando ADR non è abilitato/disabilitato in modo esplicito

Si applica a
SQL Server 2019 on Windows

Sintomi

Se non si abilita o si disabilita in modo esplicito Accelerated Database Recovery (ADR) in Microsoft SQL Server 2019, si noterà che il log degli errori di SQL Server contiene diverse voci "ADR abilitato/disabilitato", come indicato di seguito:

DateTime spid [DbId: X] ADR [Enabled/Disabled] per il database.

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Risoluzione

Questo problema è stato risolto nel seguente aggiornamento cumulativo per SQL Server:

Aggiornamento cumulativo 8 per SQL Server 2019

Informazioni sugli aggiornamenti cumulativi per SQL Server:

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

Aggiornamento cumulativo più recente per SQL Server 2019

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.