KB4582558 - FIX: SQL Server servizio non viene avviato nel sistema operativo Linux

Si applica a
SQL Server 2019 on Linux SQL Server 2017 on Linux

Sintomi

In Microsoft SQL Server eseguire il comando di configurazione sudo/opt/mssql/bin/mssql-conf. Si noti che il servizio SQL Server non viene avviato nel sistema operativo Linux, ma restituisce il messaggio di errore seguente:

Nota

DateTime.248806071 Debug [libos.trace] <0000022871/0x00000004><0x00000004/> SQLPAL: ERRORE da NTSTATUS a WIN32 in FUNC=GetProcessTimes LINE=LineNumber NTSTATUS=0xC0000008 WIN32 ERROR=0x00000006 Impossibile ottenere NtQuerySystemInformation(SystemProcessInformation

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Risoluzione

Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:

Informazioni sugli aggiornamenti cumulativi per SQL Server:

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.