Microsoft distribuisce le correzioni di Microsoft SQL Server 2008 come un unico file scaricabile. Poiché le correzioni sono cumulative, ogni nuova versione contiene tutte le correzioni rapide e di sicurezza incluse nella versione precedente di correzioni di SQL Server 2008.
Sintomi
È possibile creare o modificare un pacchetto di Microsoft SQL Server 2008 Integration Services (SSIS) in Business Intelligence Development Studio (BIDS). Si modifica un'origine OLE DB in un'attività Flusso di dati. Quando si fa clic sulla scheda Colonne , viene visualizzato il messaggio di errore seguente:
Nota
TITOLO: Microsoft Visual Studio
Errore nell Flusso di dati attività [origine OLE DB [1]]: codice di errore SSIS DTS_E_OLEDBERROR. Si è verificato un errore OLE DB. Codice di errore: 0x80040E21.
INFORMAZIONI AGGIUNTIVE:
Eccezione da HRESULT: 0xC0202009 (Microsoft.SqlServer.DTSPipelineWrap)
Nota: il codice di errore DTS_E_OLEDBERROR ha molte cause. Questo articolo descrive solo un problema raro che ha una causa specifica. Per assicurarsi che il problema si verifichi, vedere la sezione "Ulteriori informazioni" per un metodo di risoluzione dei problemi.
Nota Questo problema non si verifica in SQL Server 2005.
Causa
In SQL Server 2008 SSIS un controllo specifico determina se gli identificatori utilizzati da un provider OLE DB fanno distinzione tra maiuscole e minuscole. Questo controllo consente a SSIS di seguire la distinzione tra maiuscole e minuscole definita dalla configurazione di un provider OLE DB quando SSIS elenca nomi di oggetti, nomi di tabelle e nomi di colonna. Questo controllo viene eseguito implementando una proprietà OLE DB denominata DBPROP_IDENTIFIERCASE. Tuttavia, non tutti i provider OLE DB supportano e implementano questa proprietà. Se la proprietà non viene implementata, potrebbe verificarsi un errore nei BIDS.
Risoluzione
Informazioni sull'aggiornamento cumulativo
Versione finale di SQL Server 2008
Importante È necessario installare questo pacchetto di aggiornamento cumulativo se il computer esegue la versione finale di SQL Server 2008.
La correzione per questo problema è stata rilasciata per la prima volta nell'aggiornamento cumulativo 5. Per ulteriori informazioni su come ottenere questo pacchetto di aggiornamento cumulativo per SQL Server 2008, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
969531 Pacchetto di aggiornamento cumulativo 5 per SQL Server 2008Nota Poiché le build sono cumulative, ogni nuova versione di correzione contiene tutte le correzioni rapide e di sicurezza incluse nella versione precedente della correzione di SQL Server 2008. Si consiglia di applicare l'ultima versione della correzione che contiene questo aggiornamento rapido (hotfix). Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
956909 Le SQL Server build 2008 rilasciate dopo SQL Server 2008
SQL Server 2008 Service Pack 1
Importante È necessario installare questo pacchetto di aggiornamento cumulativo se il computer esegue SQL Server 2008 Service Pack 1.
La correzione per questo problema è stata rilasciata successivamente anche nell'aggiornamento cumulativo 3 per SQL Server 2008 Service Pack 1. Per ulteriori informazioni su questo pacchetto di aggiornamento cumulativo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
971491 Pacchetto di aggiornamento cumulativo 3 per SQL Server 2008 Service Pack 1Nota Poiché le build sono cumulative, ogni nuova versione di correzione contiene tutte le correzioni rapide e di sicurezza incluse nella versione di correzione di SQL Server 2008 precedente. Microsoft consiglia di applicare l'ultima versione della correzione che contiene questo aggiornamento rapido (hotfix). Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
970365 Le SQL Server build 2008 rilasciate dopo SQL Server rilascio del Service Pack 1 2008
Gli hotfix per Microsoft SQL Server 2008 vengono creati per Service Pack specifici di SQL Server. È necessario applicare un aggiornamento rapido rapido per SQL Server 2008 Service Pack 1 a un'installazione di SQL Server 2008 Service Pack 1. Per impostazione predefinita, qualsiasi hotfix fornito in un service pack di SQL Server è incluso nel service pack di SQL Server successivo.
Questo aggiornamento rapido (hotfix) modifica il comportamento dell'origine OLE DB in SSIS per richiedere la proprietà DBPROP_IDENTIFIERCASE. Dopo aver applicato questa correzione, SSIS ignora l'errore della proprietà DBPROP_IDENTIFIERCASE. SSIS utilizza invece un valore predefinito per gli identificatori. Dopo aver applicato questo hotfix, se il provider OLE DB non implementa la proprietà, per impostazione predefinita gli identificatori fanno distinzione tra maiuscole e minuscole.
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Altre informazioni
Risoluzione dei problemi
Per assicurarsi che il problema si verifichi, attenersi alla procedura seguente:
- Scaricare e installare lo strumento di esempio Visualizzatore set di righe OLE DB. Per ulteriori informazioni, visitare il seguente sito Web Microsoft Developer Network (MSDN):
https://msdn.microsoft.com/library/ms714336(vs.85).aspx - Avviare Visualizzatore set di righe.
- Scegliere Connessione completa dal menu File.
- Selezionare il provider, l'origine, l'account di accesso e gli altri attributi della stringa di connessione. Fare clic su OK.
- Dopo aver completato correttamente la connessione, scegliere IDBPProperties dal menu Origine dati, quindi fare clic su GetProperties.
- Nell'elenco PropSet , seleziona DBPROPSET_DATASOURCEINFO.
Se la proprietà DBPROP_IDENTIFIERCASE non è elencata come proprietà disponibile o se la proprietà DBPROP_IDENTIFIERCASE ha un punto interrogativo verde accanto alla proprietà, il provider non supporta questa proprietà. In questa situazione, incontrerai il problema descritto nella sezione "Sintomi".
Passaggi per riprodurre il problema
- In SQL Server 2008 BIDS creare un nuovo pacchetto SSIS.
- Aggiungere un'attività Flusso di dati al pacchetto.
- Aggiungere un componente Origine OLE DB nell'attività Flusso di dati.
- Configurare Gestione connessioni per l'uso di un provider OLE DB che non supporta la proprietà DBPROP_IDENTIFIERCASE.
- Selezionare una tabella, una vista o un comando SQL e quindi specificare il nome oggetto o il comando SQL richiesto.
- Nel riquadro sinistro fare clic sulla scheda Colonne .
Viene visualizzato il messaggio di errore descritto nella sezione "Sintomi".
Riferimenti
Per ulteriori informazioni sulla proprietà DBPROP_IDENTIFIERCASE, visitare il seguente sito Web Microsoft Developer Network (MSDN):
https://msdn.microsoft.com/library/ms713637(vs.85).aspx Per ulteriori informazioni sul metodo IDBProperties::GetProperties usato per eseguire query sul valore della proprietà, visitare il seguente sito Web Microsoft:
https://msdn.microsoft.com/library/ms714344(vs.85).aspxPer ulteriori informazioni sul modello di servizio incrementale per SQL Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
935897 un modello di manutenzione incrementale è disponibile dal team SQL Server per fornire correzioni rapide per i problemi segnalati
Per ulteriori informazioni sullo schema di denominazione per gli aggiornamenti di SQL Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
822499 Nuovo schema di denominazione per i pacchetti di aggiornamento software Microsoft SQL Server Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft