Sintomi
Si supponga di utilizzare Strumentazione gestione Windows (WMI) per monitorare gli eventi in Microsoft SQL Server. In questa situazione, una perdita di memoria nel file di sqlwepxxx.dll causa l'arresto anomalo del processo di WmiPrvSe.exe e i seguenti messaggi di errore vengono registrati nel registro degli errori di SQL Server:
Nota
- Messaggio di errore 1
- Errore: 17003, gravità: 16, stato: 1.
Endpoint di conversazione di notifica evento chiuso con handle '{CF29E9B8-33FA-E711-80DC-005056BB2DA5}', a causa dell'errore seguente: '<?xml version="1.0"?><Error xmlns="http://schemas.microsoft.com/SQL/ServiceBroker/Error"Code-8470><<>/Code><Description>Il servizio remoto è stato abbandonato.</Descrizione></Errore>".
Nota
- Messaggio di errore 2
- Errore: 17001, gravità: 16, stato: 1.
Mancato invio di un'istanza di notifica degli eventi di tipo 'ERRORLOG' nell'handle di conversazione '{D229E9B8-33FA-E711-80DC-005056BB2DA5}'. Codice di errore = '8429'.
Nota
- Messaggio di errore 3
- Errore: 17005, gravità: 16, stato: 1.
Notifica evento 'SQLWEP_F7B4409C_33AD_4027_8008_07E894E7886F' nel database 'master' ignorato a causa di errori di Service Broker dell'orario di invio. Verificare che l'handle di conversazione, il contratto del broker di servizi e il servizio specificato nella notifica dell'evento siano attivi.
Nel registro eventi dell'applicazione viene inoltre registrato un messaggio di errore simile al seguente:
Nota
Data e ora Avviso server_name 5612 Microsoft-Windows-WMI N/A NT AUTHORITY\SYSTEM Strumentazione gestione Windows ha interrotto WMIPRVSE.EXE perché una quota ha raggiunto un valore di avviso. Quota: PrivatePageCount Valore: 537690112 Valore massimo: 536870912 PID WMIPRVSE: 4244 Provider ospitati in questo processo: C:\Windows\System32\wbem\WmiPerfClass.dll, C:\Program Files\Microsoft SQL Server\120\COM\sqlwep120.dll, C:\Program Files\Microsoft SQL Server\120\COM\sqlwep120.dll
Avvertenza Il file sqlwep120.dll è il file SQLWEP in SQL Server 2014.
Risoluzione
Questo problema è stato risolto nei seguenti aggiornamenti per SQL Server:
Aggiornamento cumulativo 10 per SQL Server 2017
Aggiornamento cumulativo 3 per SQL Server 2016 SP2
Aggiornamento cumulativo 11 per SQL Server 2016 SP1
Aggiornamento cumulativo 12 per SQL Server 2014 Service Pack 2
Informazioni sugli aggiornamenti cumulativi per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni a caldo e di sicurezza presenti nella build precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
Aggiornamento cumulativo più recente per SQL Server 2017
Aggiornamento cumulativo più recente per SQL Server 2016
gli aggiornamenti cumulativi più recenti per SQL Server 2014
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.