KB4551220 - FIX: Si verifica un errore di asserzione quando si esegue l'istruzione di compilazione dell'indice ripristinabile in SQL Server

Si applica a
SQL Server 2017 Developer SQL Server 2017 Enterprise SQL Server 2017 Enterprise Core SQL Server 2017 Standard on Windows SQL Server 2017 Standard on Linux SQL Server 2019 on Linux SQL Server 2019 on Windows

Sintomi

Si supponga di eseguire un comando di ricostruzione ALTER INDEX con l'opzione RESUMABLE=ON in Microsoft SQL Server. Se si tratta di un indice filtrato che include una condizione come la colonna IS NULL, l'operazione potrebbe avere esito negativo e restituire un errore di asserzione. Inoltre, potrebbe essere generato un file dump di arresto anomalo del sistema.

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Risoluzione

Questo problema è stato risolto nel seguente aggiornamento cumulativo per SQL Server:

Nota: A seconda della struttura dell'indice e della condizione dell'indice filtrato, la versione di SQL Server non può completare in modo sicuro la compilazione dell'indice ripristinabile. Dopo l'installazione di CU, invece di generare un'asserzione e un dump, SQL Server termina normalmente l'operazione e restituisce un nuovo codice di errore 10675.

"Errore del processore di query interno: il processore di query non è riuscito a produrre un piano di query. L'opzione RESUMABLE non è supportata per questa build dell'indice. Rimuovere l'opzione RESUMABLE ed eseguire nuovamente l'istruzione."
      

Informazioni sugli aggiornamenti cumulativi per SQL Server:

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.