KB2645648 - FIX: La procedura di esportazione non riesce quando si esporta un report SSRS 2008 R2 a 64 bit, un report SSRS 2012 o un report SSRS 2008 che contiene più livelli di una mappa documento in formato PDF

Si applica a
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Express SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2012 Enterprise Core

Microsoft distribuisce le correzioni di Microsoft SQL Server 2008 R2 Service Pack 1 (SP1) o Microsoft SQL Server 2008 in un file scaricabile. Poiché le correzioni sono cumulative, ogni nuova versione contiene tutte le correzioni rapide e tutti gli aggiornamenti della sicurezza inclusi nella precedente versione di aggiornamento di SQL Server 2008 R2 Service Pack 1 (SP1) o SQL Server 2008.

Sintomi

Si consideri lo scenario seguente:

  • Si dispone di un report in un'istanza a 64 bit di Microsoft SQL Server 2008 R2 Reporting Services (SSRS 2008 R2), in un'istanza di Microsoft SQL Server 2008 Reporting Services (SSRS 2008) o in un'istanza di Microsoft SQL Server 2012 Reporting Services (SSRS 2012).
  • Il report contiene più livelli di una mappa documento.
  • Si tenta di esportare il report in formato PDF.

In questo scenario la procedura di esportazione ha esito negativo e viene visualizzato il seguente messaggio di errore:

Nota

Il server remoto ha restituito un errore: (500) Errore interno del server.

Nel file di log SSRS viene inoltre registrato l'errore seguente:

Nota

rshost!rshost!bb8!<Data><e ora>:: e ERRORE: Impossibile elaborare la richiesta 0x80131014, pipeline=0x0000000002B99080.
Interfaccia utente! ReportManager_0-84!ee8!<Data><e ora>:: Eccezione non gestita: Microsoft.Reporting.WebForms.ReportServerException: Il server remoto ha restituito un errore: (500) Errore interno del server. >--- System.Net.WebException: Il server remoto ha restituito un errore: (500) Errore interno del server.

        
Note

  • È comunque possibile eseguire correttamente il rendering del report in formato HTML.
  • Questo problema non si verifica se SSRS 2008 R2 è installato in un computer che esegue un sistema operativo a 32 bit.

Causa

Questo problema si verifica a causa di una limitazione del renderer PDF di SSRS.

Risoluzione

Informazioni sull'aggiornamento cumulativo

Aggiornamento cumulativo 1 per SQL Server 2012 Service Pack 1

La correzione di questo errore è stata rilasciata per la prima volta nell'aggiornamento cumulativo 1. Per ulteriori informazioni su come ottenere questo pacchetto di aggiornamento cumulativo per SQL Server 2012 Service Pack 1, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

2765331 Pacchetto di aggiornamento cumulativo 1 per SQL Server 2012 Service Pack 1Nota Poiché le build sono cumulative, ogni nuova versione di correzione contiene tutte le correzioni rapide e di sicurezza incluse nella versione precedente della correzione di SQL Server 2012. Si consiglia di applicare l'ultima versione della correzione che contiene questo aggiornamento rapido (hotfix). Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

2772858 Le SQL Server build 2012 rilasciate dopo il rilascio SQL Server Service Pack 1 2012

SQL Server 2012

La correzione di questo problema è stata rilasciata per la prima volta nell'aggiornamento cumulativo 3 per SQL Server 2012. Per ulteriori informazioni su questo pacchetto di aggiornamento cumulativo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

2723749 Pacchetto di aggiornamento cumulativo 3 per SQL Server 2012Nota Poiché le build sono cumulative, ogni nuova versione di correzione contiene tutte le correzioni rapide e di sicurezza incluse nella versione precedente della correzione di SQL Server 2012. Microsoft consiglia di applicare l'ultima versione della correzione che contiene questo aggiornamento rapido (hotfix). Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

2692828 Le build di SQL Server 2012 rilasciate dopo il rilascio di SQL Server 2012 È necessario applicare un aggiornamento rapido SQL Server 2012 a un'installazione di SQL Server 2012.

SQL Server 2008 Service Pack 3

La correzione per questo problema è stata rilasciata per la prima volta nell'aggiornamento cumulativo 6 per SQL Server 2008 Service Pack 3. Per ulteriori informazioni su questo pacchetto di aggiornamento cumulativo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

2715953 Pacchetto di aggiornamento cumulativo 6 per SQL Server 2008 Service Pack 3Nota Poiché le build sono cumulative, ogni nuova versione di correzione contiene tutte le correzioni rapide e di sicurezza incluse nella versione di correzione di SQL Server 2008 precedente. Microsoft consiglia di applicare l'ultima versione della correzione che contiene questo aggiornamento rapido (hotfix). Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

2629969 Le build SQL Server 2008 rilasciate dopo il rilascio del Service Pack 3 SQL Server 2008 Microsoft SQL Server 2008 vengono create per Service Pack specifici di SQL Server. È necessario applicare un aggiornamento rapido rapido per SQL Server 2008 Service Pack 3 a un'installazione di SQL Server 2008 Service Pack 3. Per impostazione predefinita, qualsiasi hotfix fornito in un service pack di SQL Server è incluso nel service pack di SQL Server successivo.

SQL Server 2008 Service Pack 2

La correzione di questo problema è stata rilasciata per la prima volta nell'aggiornamento cumulativo 8 per SQL Server 2008 Service Pack 2. Per ulteriori informazioni su questo pacchetto di aggiornamento cumulativo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

2648096 Pacchetto di aggiornamento cumulativo 8 per SQL Server 2008 Service Pack 2Nota Poiché le build sono cumulative, ogni nuova versione di correzione contiene tutte le correzioni rapide e di sicurezza incluse nella versione di correzione di SQL Server 2008 precedente. Microsoft consiglia di applicare l'ultima versione della correzione che contiene questo aggiornamento rapido (hotfix). Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

2402659 Le build di SQL Server 2008 rilasciate dopo il rilascio del Service Pack 2 SQL Server 2008, gli hotfix di Microsoft SQL Server 2008 vengono creati per Service Pack SQL Server specifici. È necessario applicare un aggiornamento rapido rapido per SQL Server 2008 Service Pack 2 a un'installazione di SQL Server 2008 Service Pack 2. Per impostazione predefinita, qualsiasi hotfix fornito in un service pack di SQL Server è incluso nel service pack di SQL Server successivo.

Aggiornamento cumulativo 4 per SQL Server 2008 R2 SP1

La correzione per questo errore è stata rilasciata per la prima volta nell'aggiornamento cumulativo 4. Per ulteriori informazioni su come ottenere questo pacchetto di aggiornamento cumulativo per SQL Server 2008 R2 SP1, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

2633146 Pacchetto di aggiornamento cumulativo 4 per SQL Server 2008 R2 SP1Nota: poiché le build sono cumulative, ogni nuova versione di correzione contiene tutte le correzioni rapide e di sicurezza incluse nella versione precedente della correzione di SQL Server 2008 R2 SP1. Si consiglia di applicare l'ultima versione della correzione che contiene questo aggiornamento rapido (hotfix). Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

2567616 Le SQL Server build 2008 R2 rilasciate dopo il rilascio di SQL Server 2008 R2 SP1

Soluzione alternativa

Per risolvere questo problema, usare meno livelli di mappe documento.

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".