KB4019983 - FIX: Errore "Indice non compreso nell'intervallo" durante l'esportazione in formato PDF in un report SQL Server Reporting Services

Si applica a
SQL Server 2014 Service Pack 2 - duplicate (do not use) SQL Server 2016 Service Pack 1

Sintomi

Si supponga di usare SQL Server Reporting Services. Quando si esporta un report in formato PDF o si esegue un'anteprima di stampa per un report in Visual Studio 2015, è possibile che venga visualizzato il messaggio di errore seguente se una colonna del report si espande da una pagina a quella successiva:

Nota

Si è verificato un errore durante il rendering del report. (rrRenderingError)
Si è verificato un errore durante il rendering del report.
L'indice era fuori intervallo. Deve essere non negativo e inferiore alle dimensioni della raccolta. Nome parametro: indice.

Risoluzione

Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:

Aggiornamento cumulativo 7 per SQL Server 2016 RTM

Aggiornamento cumulativo 6 per SQL Server 2014 SP2

Aggiornamento cumulativo 13 per SQL Server 2014 SP1

Aggiornamento cumulativo 9 per SQL Server 2012 Service Pack 3

Consiglio: installare l'aggiornamento cumulativo più recente per SQL Server

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

Aggiornamento cumulativo più recente per SQL Server 2016

Aggiornamento cumulativo più recente per SQL Server 2014

Aggiornamento cumulativo più recente per SQL Server 2012 SP3

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.