Sintomi
Si supponga di abilitare la funzionalità MARS (Multiple Active Result Sets) in Microsoft SQL Server 2014 e di impostare l'opzione MAXDOP (Max Degree of Parallelism) su un valore maggiore di 1. Tuttavia, quando si esegue una query parallela contenente istruzioni MERGE in tabelle indicizzate cluster columnstore tramite la connessione MARS, viene visualizzato il messaggio di errore seguente:
Avviso
errore 35377: Quando MARS è attivato, l'accesso agli indici cluster columnstore non è consentito.
Nota Questo problema non si verifica quando si imposta MAXDOP su 1.
Risoluzione
Il problema è stato risolto per la prima volta nei seguenti aggiornamenti cumulativi SQL Server:
Aggiornamento cumulativo 1 per SQL Server 2014 SP1
Aggiornamento cumulativo 8 per SQL Server 2014
Informazioni sugli aggiornamenti cumulativi per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutti gli aggiornamenti rapidi e le correzioni per la sicurezza inclusi nell'aggiornamento cumulativo precedente. Per gli aggiornamenti cumulativi più recenti per SQL Server, vedere:
Ultimo aggiornamento cumulativo per SQL Server 2014 SP1
Ultimo aggiornamento cumulativo per SQL Server 2014
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".