Sintomi
Si supponga di usare Microsoft SQL Server 2014 o 2016. Quando si verifica l'utilizzo della memoria disponibile nei nodi NUMA, si nota che la memoria nodo di database (KB) è inferiore al 2% delle dimensioni di destinazione. In questo caso, potrebbe essere visualizzato il seguente messaggio di errore "Memoria esaurita":
Data/ora spid36s Impossibile allocare i file BUF:FAIL_BUFFER_ALLOCATION 1
Questo problema si verifica anche se è disponibile molta memoria in SQL Server.
Causa
Un errore "Memoria esaurita" può verificarsi quando la memoria del nodo di database (KB) diventa inferiore al 2% delle dimensioni di destinazione e non può più eliminare le pagine di database nel nodo per ottenere pagine gratuite.
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Risoluzione
Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:
Informazioni sugli aggiornamenti cumulativi per SQL Server:
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutti gli aggiornamenti rapidi e tutte le correzioni per la sicurezza inclusi nell'aggiornamento cumulativo precedente. Scopri gli aggiornamenti cumulativi più recenti per SQL Server:
Nota Dopo aver applicato questa correzione, SQL Server sarà in grado di recuperare le pagine dai nodi del buffer remoto se il numero di pagine di database nel nodo locale scende al di sotto del 2% delle pagine di destinazione.
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.