KB4475322 - CORREZIONE: l'errore "Non yielding" si verifica quando si verifica un uso intensivo delle istruzioni preparate in SQL Server 2014, 2016 e 2017

Si applica a
SQL Server 2014 Service Pack 2 - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1 SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Sintomi

Si supponga di utilizzare un'applicazione per connettersi a un'istanza di Microsoft SQL Server 2014, 2016 e 2017. Se si usa in modo intensivo la stored procedure ( SP) sp_prepare che non è immediatamente seguita da sp_unprepare, vengono generate molte voci memorizzate nella cache degli handle SQL. Inoltre, nel log degli errori potrebbe essere visualizzato un errore di utilità di pianificazione non cedente.

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Risoluzione

Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:

Informazioni sugli aggiornamenti cumulativi per SQL Server:
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutti gli aggiornamenti rapidi e tutte le correzioni per la sicurezza inclusi nell'aggiornamento cumulativo precedente. Scopri gli aggiornamenti cumulativi più recenti per SQL Server:

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.