KB4510934 - CORREZIONE: l'utilizzo prolungato non transazionale di FileTable senza riavvio dell'istanza può causare un errore di utilità di pianificazione non cedente o un arresto anomalo del server in SQL Server 2014, 2016 e 2017

Si applica a
SQL Server 2014 Service Pack 2 - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 Developer on Windows SQL Server 2017 Enterprise Core on Windows SQL Server 2017 Enterprise on Windows SQL Server 2017 Standard Windows

Sintomi

Si supponga che FileTable venga usato dalle API I/O file in una condizione di traffico elevato per molto tempo senza riavviare l'istanza. In questo scenario potrebbe verificarsi un errore di utilità di pianificazione non yielding, un utilizzo della CPU al 100% o un arresto anomalo del server. Questo problema si verifica quando una richiesta utente tocca un ciclo infinito internamente.

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Risoluzione

Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:

Informazioni sugli aggiornamenti cumulativi per SQL Server:

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutti gli aggiornamenti rapidi e tutte le correzioni per la sicurezza inclusi nell'aggiornamento cumulativo precedente. Scopri gli aggiornamenti cumulativi più recenti per SQL Server:

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.