Sintomi
Si supponga di creare una sessione di query in un database contenente tabelle e tipi di tabella ottimizzati per la memoria. Quando si esegue una query nella visualizzazione sys.sysindexes del database, la sessione di query viene terminata. Viene inoltre visualizzato un messaggio di errore simile al seguente:
Nota
Msg 3624, livello 20, stato 1, linea 12
Un controllo dell'asserzione di sistema non è riuscito. Per informazioni dettagliate, controllare il log degli errori SQL Server. In genere, un errore di asserzione è causato da un bug del software o dal danneggiamento dei dati. Per verificare se il database è danneggiato, è consigliabile eseguire DBCC CHECKDB. Se hai accettato di inviare dump a Microsoft durante l'installazione, un mini dump verrà inviato a Microsoft. Un aggiornamento potrebbe essere disponibile da Microsoft nel Service Pack più recente o in un aggiornamento rapido dal supporto tecnico.
Msg 596, Livello 21, Stato 1, Riga 11
Non è possibile continuare l'esecuzione perché la sessione è nello stato kill.
Errore grave msg 0, livello 20, stato 0, riga 11A grave nel comando corrente. I risultati, se presenti, devono essere scartati.
Nota Se si esegue DBCC CHECKDB nel database per verificare se il database è danneggiato, non viene segnalato alcun errore.
Risoluzione
Il problema è stato risolto per la prima volta nel seguente aggiornamento cumulativo di SQL Server:
Consiglio: installare l'aggiornamento cumulativo più recente per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutti gli aggiornamenti rapidi e tutte le correzioni per la sicurezza inclusi nell'aggiornamento cumulativo precedente. È consigliabile scaricare e installare gli aggiornamenti cumulativi più recenti per SQL Server:
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.