Sintomi
Si consideri lo scenario seguente:
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Creare un cluster di failover basata su Windows Server 2012 e utilizza le risorse disco dinamico di terze parti.
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Si configura una risorsa di servizio File Server nello snap-in Gestione Cluster di Failover.
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Si tenta di aggiungere una condivisione di file del cluster nella risorsa servizio File Server.
In questo scenario, si verificano i seguenti problemi:
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Non è possibile creare una condivisione file del cluster utilizzando il menu di scelta rapida Aggiungere condivisione File .
Nota: Se non si avvia il menu di scelta rapida Aggiungere condivisione File , installare l'hotfix descritto nell' articolo di Microsoft Knowledge Base (KB) 2795993 per risolvere il problema. -
Quando si tenta di creare una condivisione file del cluster utilizzando Esplora File, viene creata una condivisione Server Message Block (SMB) anziché una condivisione di file del cluster del volume. Ad esempio, si supponga che si tenta di creare una condivisione file del cluster denominato "ContosoShare" utilizzando Esplora File su un'unità denominata "ThirdPartyDisk" utilizzando la seguente configurazione:
Nome cluster: ContosoCluster
Risorsa di File server del cluster: \ \ContosoFileShare
Risorse di archiviazione di terze parti che \ \ContosoFileShare dipende: ThirdPartyDisk
Nome server/nodo: ContosoClusterNode1
Nome condivisione: ContosoShare
In questo caso, la condivisione di file è accessibile tramite il percorso "\ContosoShareContosoClusterNode1\\" anziché il percorso "\\ContosoFileShare\ContosoShare". -
Non è possibile creare una condivisione file del cluster utilizzando l'API NetShare o un comando di Windows PowerShell. Inoltre, viene visualizzato un messaggio di errore analogo al seguente:
Errore di sistema 87 – il parametro non è corretto
Causa
Questo problema si verifica perché il cluster di failover basata su Windows Server 2012 non determina correttamente il disco dinamico di terze parti da un disco del cluster.
Risoluzione
Informazioni sull'hotfix
Esempi di prodotti che utilizzano risorse di classe di archiviazione di terze parti che è necessario applicare questo hotfix se si utilizzano questi prodotti includono (ma non è limitati a):
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Archiviazione di Symantec Foundation per Windows
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Visione soluzioni Double-Take di disponibilità
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SIOS DataKeeper Cluster Edition
Per risolvere questi problemi, installare l'hotfix descritto in questo articolo. Inoltre, è possibile installare gli aggiornamenti rapidi descritti in KB 2795993 e 2795997 KB per risolvere tutti i problemi correlati. Per ulteriori informazioni su KB 2795993 e 2795997 KB, fare clic sui numeri per visualizzare gli articoli della Microsoft Knowledge Base riportato di seguito:
2795993 Condivisione guidata non viene avviato quando si tenta di creare una condivisione file del cluster su una risorsa disco dinamico di terze parti in Windows 8 o Windows Server 2012
2795997 dell'interfaccia utente viene visualizzato correttamente su una risorsa disco dinamico di terze parti nell'area di archiviazione disponibile in Windows Server 2012
Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico.
Se l'hotfix è disponibile per il download, vi è una sezione "Hotfix Download disponibile" nella parte superiore di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta al servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.
Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix Download disponibile" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.
Prerequisiti
Per applicare questo hotfix, è necessario eseguire Windows Server 2012.
Informazioni del Registro di sistema
Per utilizzare l'hotfix in questo pacchetto, non è necessario apportare modifiche al Registro di sistema.
Richiesta di riavvio
Dopo avere applicato questo hotfix, è necessario riavviare il computer.
Informazioni sulla sostituzione dell'aggiornamento rapido
Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.
La versione globale di questo hotfix consente di installare file con gli attributi elencati nelle tabelle seguenti. Le date e ore per questi file sono elencate nel tempo universale coordinato (UTC). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e gli orari possono cambiare quando si eseguono determinate operazioni sui file.
Note di informazioni file di Windows Server 2012Importante Aggiornamenti rapidi di Windows 8 e aggiornamenti rapidi di Windows Server 2012 sono inclusi nel pacchetto stesso. Tuttavia, solo "Windows 8" è elencato nella pagina richiesta Hotfix. Per richiedere il pacchetto di hotfix che si applica a uno o entrambi i sistemi operativi, selezionare l'hotfix elencato nella pagina in "Windows 8". Fare sempre riferimento alla sezione "Si applica a" negli articoli per determinare il sistema operativo effettivo a cui si applica ogni aggiornamento rapido .
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I file relativi a un prodotto, un'attività cardine (RTM, SPn) e un ramo (LDR, GDR specifici) del servizio possono essere identificati esaminando i numeri di versione del file come indicato nella tabella seguente:
Versione
Prodotto
Attività cardine
Ramo del servizio
6.2.920 0,20 xxx
Windows Server 2012
RTM
LDR
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I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono elencati separatamente nella sezione "Ulteriori informazioni sui file per Windows Server 2012". MUM e file MANIFEST e i file di catalogo (CAT) di protezione associato, sono estremamente importanti per mantenere lo stato dei componenti aggiornati. I file catalogo di protezione elencati senza attributi sono firmati con firma digitale Microsoft.
Per tutte le versioni basate su x64 supportate di Windows Server 2012
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
---|---|---|---|---|---|
Clusapi.dll |
6.2.9200.16384 |
372,224 |
26-Jul-2012 |
03:05 |
x64 |
Resutils.dll |
6.2.9200.16493 |
626,688 |
04-Jan-2013 |
09:30 |
x64 |
Clusapi.dll |
6.2.9200.16384 |
372,224 |
26-Jul-2012 |
03:05 |
x64 |
Resutils.dll |
6.2.9200.20598 |
626,688 |
04-Jan-2013 |
09:22 |
x64 |
Stato
Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".
Ulteriori informazioni
Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:
824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software MicrosoftI prodotti di terze parti descritti in questo articolo sono forniti da società indipendenti da Microsoft. Microsoft esclude ogni garanzia, implicita o esplicita relativa alle prestazioni o all'affidabilità di tali prodotti.
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