Sintomi

Quando si tenta di eliminare delle cartelle memorizzate su un'unità montata e di inviarle al Cestino, è possibile che venga visualizzato il seguente messaggio di errore:

Impossibile eliminareNomeCartella: Accesso negato. Il file di origine potrebbe essere in uso.

Cause

Questo comportamento si verifica in quanto il Cestino non riconosce i volumi montati. Si supponga ad esempio di disporre del seguente layout di unità:

C: -- unità da 1 gigabyte (GB) con file system NTFSC:\Host-dir -- Punto di montaggio per un'altra unità da 9 GB Quando si tenta di eliminare una cartella con percorso C:\Host-dir\Mydir, questa viene interpretata come appartenente all'unità C da parte di Esplora risorse di Windows, il quale tenta inutilmente di inserirla nel Cestino sull'unità C.

Workaround

Per aggirare il problema, utilizzare uno dei metodi descritti di seguito:

  • Quando si eliminano file o cartelle in Esplora risorse utilizzare la combinazione di tasti MAIUSC+CANC, che evita il trasferimento al Cestino.

  • Aprire la finestra del prompt dei comandi e utilizzare il comando rd /s /q per eliminare file o cartelle.

Nota Entrambi i metodi consentono di eliminare i dati in modo permanente. Questo significa che non sarà più possibile ripristinarli a meno di non disporre di una copia di backup aggiornata.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine del presente articolo.

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.