"La cassetta postale non ha un profilo del server di posta elettronica associato o il profilo del server di posta elettronica è inattivo" si verifica in Microsoft Dynamics 365

Questo articolo fornisce una soluzione a un errore che si verifica dopo aver selezionato il pulsante Test & Abilita cassetta postale in Dynamics 365.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4484702

Sintomi

Dopo aver selezionato il pulsante Test & Abilita cassetta postale in Dynamics 365, i risultati del test vengono visualizzati come Errore e viene visualizzato l'errore seguente nella scheda Avvisi della cassetta postale:

"non è possibile ricevere Email perché alla cassetta postale [Nome cassetta postale] non è associato un profilo del server di posta elettronica o il profilo del server di posta elettronica è inattivo.
codice di errore del server Email: InvalidIncomingEmailServerProfile"

Causa

Questo errore verrà visualizzato se il record della cassetta postale dell'utente in Dynamics 365 non ha un valore specificato per il campo Profilo server o se il profilo del server associato è disattivato.

Risoluzione

  1. Aprire il record della cassetta postale in Dynamics 365 e verificare che nel campo Profilo server sia selezionato un valore.
  2. Se un valore è già selezionato, aprire il profilo del server associato ed esaminare lo stato visualizzato nella parte inferiore della pagina.
  3. Se il profilo del server Email mostra lo stato Inattivo, seguire questa procedura:
    1. Passare a Impostazioni, configurazione Email e profili server di Email.
    2. Impostare la visualizzazione su Profili server Email inattivi.
    3. Selezionare il Email Profilo server, selezionare Attiva e quindi ok.
  4. Tornare al record della cassetta postale e quindi selezionare il pulsante Test e Abilita cassetta postale .
  5. Se i risultati del test vengono visualizzati come Errore, visualizzare la sezione Avvisi.