Il nome alias alias tabella non è univoco quando si aprono determinate viste in Microsoft Dynamics CRM 2011

Questo articolo fornisce una soluzione a un problema per cui potrebbe non essere possibile aprire le visualizzazioni dopo Microsoft Dynamics CRM aggiornamento cumulativo 12 di Microsoft Dynamics CRM 2011.

Si applica a: Microsoft Dynamics CRM 2011
Numero KB originale: 2907665

Sintomi

Un utente potrebbe non essere in grado di aprire le visualizzazioni dopo l'aggiornamento cumulativo 12. Questo problema si verifica quando le visualizzazioni di tipo Visualizzazione ricerca avanzata vengono modificate in modo che i campi delle entità correlate vengano aggiunti alla colonna di visualizzazione. Il problema viene identificato sia con entità predefinite che con entità personalizzate.

Causa

Durante la modifica della visualizzazione, il nodo link-entity è disponibile due volte. Tuttavia, per un singolo tipo di nodo di entità di collegamento, deve essere disponibile una sola volta.

Risoluzione

L'installazione di Microsoft Dynamics CRM aggiornamento cumulativo 2011 15 risolve il problema relativo alle visualizzazioni modificate dopo l'installazione dell'aggiornamento cumulativo 15. Le viste esistenti identificate prima dell'installazione dell'aggiornamento cumulativo 15 che genera l'errore devono essere corrette manualmente.

Di seguito è riportato un esempio che illustra come risolvere il problema in una visualizzazione interrotta esistente:

È come riprodurre il problema:

  1. Passare a Impostazioni, selezionare Personalizzazioni, selezionare Personalizza il sistema, selezionare Entità, selezionare Account e quindi Visualizza.
  2. Aprire La visualizzazione Ricerca avanzata account e selezionare Aggiungi colonne.
  3. Selezionare Entità correlata contatto primario (contatto) nell'elenco a discesa Tipo di record .
  4. Selezionare la casella di controllo accanto a Nome completo e selezionare OK.
  5. Selezionare Salva e chiudi.
  6. Selezionare Pubblica tutte le personalizzazioni.
  7. Aprire la visualizzazione Account inattivi e selezionare Modifica criteri filtro.
  8. Aggiungere/modificare/eliminare eventuali criteri di filtro (modificare Stato = Inattivo in Stato = Attivo), selezionare OK e selezionare Salva e chiudi.
  9. Selezionare Pubblica tutte le personalizzazioni.
  10. Anche in questo caso, nella visualizzazione Account inattivi selezionare Modifica criteri filtro e Aggiungi/modifica/elimina eventuali criteri di filtro (modifica stato = Attivo in Stato = Inattivo).
  11. Seleziona OK.
  12. Selezionare Salva e chiudi.
  13. Selezionare Pubblica tutte le personalizzazioni.
  14. Passare a Ricerca avanzata e selezionare Account nell'elenco a discesa Cerca: e selezionare Account inattivi nell'elenco a discesa Usa visualizzazione salvata .
  15. Selezionare Risultati.

Ecco come è stato risolto (usando l'esempio precedente usato per riprodurre il problema):

  1. Avviare l'applicazione CRM 2011.

  2. Passare a Impostazioni, scegliere Personalizzazioni e selezionare Soluzioni.

  3. Creare una nuova soluzione e aggiungervi un'entità Account senza aggiungere dipendenze.

  4. Salvare la soluzione ed esportarla come soluzione non gestita.

  5. Dopo aver salvato il file ZIP della soluzione non gestita, estrarre il file.

  6. Aprire customizations.xml file in un editor XML come Visual Studio 2012 e selezionare CTRL+M+M sulla tastiera per comprimere il codice XML completo.

  7. Cercare il nome della visualizzazione che generava un errore. In questo caso, si tratta di account inattivi e sarà presente una sola volta nell'intero file.

  8. Espanderà solo una query salvata nel codice XML.

  9. In questa sezione espandere l'elemento <fetchxml> e cercare <Link-entity>.

  10. Si noterà che il codice XML seguente è duplicato:

    <link-entity name="contact" from="contactid" to="primarycontactid" visible="false" link- type="outer" alias="a_410707b195544cd984376608b1802904">
    
    <attribute name="fullname" />
    
    <attribute name="emailaddress1" />
    
    </link-entity>
    

    Dovrebbe essere presente solo una volta.

  11. Rimuovere una voce del codice XML da customizations.xml file e salvare le modifiche.

  12. Comprimere nuovamente i file con customizations.xmlmodificati , [content_Types].xml e solution.xml.

  13. Importare questo file ZIP nell'applicazione CRM e pubblicare tutte le personalizzazioni.

  14. Risolverà il problema relativo alle visualizzazioni inattive dell'account. Questo è il modo in cui è possibile correggere tutte le altre visualizzazioni che generano questo errore.