Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

In questo articolo viene descritto un problema quando il proxy di AD FS e le prestazioni di STS è lento in Windows Server 2012 R2. Il problema viene risolto nell'aggiornamento cumulativo 2955164 per Windows 8.1 o Windows Server 2012 R2 o aggiornamento rapido 2948086 descritta in questo articolo e è un prerequisito.

Sintomi

Si supponga di disporre di una protezione servizio (token) installato in un computer basato su Windows Server 2012 R2. Quando più client (client oltre 200) tenta di accedere utilizzando un proxy di Active Directory Federation Services (ADFS), il proxy di AD FS consuma 100% di utilizzo della CPU. In questo caso, le prestazioni del proxy di AD FS sono lenta e causa un ritardo che supera 10seconds. In questo modo anche STS funzionare con un carico minimo. Pertanto, STS rifiuterà le richieste o serve solo da 5 a 10 richieste al secondo.

Causa

Questo problema si verifica perché le richieste aggiuntive "obsoleti" vengono aggiunti al pool di richiesta quando più client tenta di accedere. Pertanto, l'utilizzo delle risorse in ADFS è esaurita.

Risoluzione

Per risolvere questo problema, installare l'aggiornamento cumulativo 2955164 o installare l'hotfix descritto in questo articolo.

Informazioni sull'aggiornamento

Per ulteriori informazioni su come ottenere questo aggiornamento, fare clic sul numero seguente per visualizzare l'articolo della Microsoft Knowledge Base:

2955164 Windows RT 8.1, 8.1 di Windows e Windows Server 2012 R2 rollup di aggiornamento: maggio 2014

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico.

Se l'hotfix è disponibile per il download, vi è una sezione "Hotfix Download disponibile" nella parte superiore di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta al servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix Download disponibile" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è innanzitutto necessario installare l'aggiornamento 2919355 in Windows Server 2012 R2. Per ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

2919355 Windows RT 8.1, 8.1 Windows e Windows Server 2012 R2 aggiornamento aprile 2014

Informazioni del Registro di sistema

Per utilizzare l'hotfix in questo pacchetto, non è necessario apportare modifiche al Registro di sistema.

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

La versione globale di questo hotfix consente di installare file con gli attributi elencati nelle tabelle seguenti. Le date e ore per questi file sono elencate nel tempo universale coordinato (UTC). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e gli orari possono cambiare quando si eseguono determinate operazioni sui file.

Note e informazioni sui file di Windows Server 2012 R2Importante Gli aggiornamenti rapidi Windows 8.1 e aggiornamenti rapidi di Windows Server 2012 R2 sono inclusi nel pacchetto stesso. Tuttavia, gli aggiornamenti rapidi nella pagina richiesta Hotfix sono elencati in entrambi i sistemi operativi. Per richiedere il pacchetto di hotfix che si applica a uno o entrambi i sistemi operativi, selezionare l'hotfix elencato nella pagina in "Windows 8.1 e Windows Server 2012 R2". Fare sempre riferimento alla sezione "Si applica a" negli articoli per determinare il sistema operativo effettivo a cui si applica ogni aggiornamento rapido .

  • I file relativi a un prodotto, un'attività cardine (RTM, SPn) e un ramo (LDR, GDR specifici) del servizio possono essere identificati esaminando i numeri di versione del file come indicato nella tabella seguente:

    Versione

    Prodotto

    Attività cardine

    Ramo del servizio

    6.3.960 0,17xxx

    Windows Server 2012 R2

    RTM

    GDR

  • I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono elencati separatamente nella sezione "Ulteriori informazioni sui file". MUM, manifesto e i file di catalogo (CAT) di protezione associati sono molto importanti per mantenere lo stato dei componenti aggiornati. I file catalogo di protezione elencati senza attributi sono firmati con firma digitale Microsoft.

Per tutte le versioni basate su x64 supportate di Windows Server 2012 R2

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Microsoft.identityserver.claimspolicy.dll

6.3.9600.17078

212,992

22-Mar-2014

21:47

x64

Microsoft.identityserver.proxyservice.exe

6.3.9600.17078

71,680

22-Mar-2014

21:47

x64

Microsoft.identityserver.service.dll

6.3.9600.17078

668,160

22-Mar-2014

21:47

x64

Microsoft.identityserver.webhost.dll

6.3.9600.17078

172,544

22-Mar-2014

21:47

x64


Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft.

Ulteriori informazioni sui file

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×