Consigli Questo articolo contiene una sezione che illustra come ridurre le impostazioni di sicurezza o disattivare le funzionalità di sicurezza in un computer. È possibile apportare queste modifiche per risolvere un problema specifico. Tuttavia, prima di apportare queste modifiche, è consigliabile valutare i rischi associati all'implementazione di questa soluzione alternativa in un particolare ambiente. Se si implementa questa soluzione alternativa, assicurarsi di seguire le procedure aggiuntive appropriate per proteggere il computer.
INTRODUZIONE
Questo articolo descrive come risolvere i problemi di prestazioni in Microsoft Outlook.
È possibile che si verifichino uno o più dei problemi di prestazioni seguenti in Outlook:
- Outlook sembra non rispondere.
- Outlook sembra smettere di rispondere per molto tempo.
Altre informazioni
I problemi di prestazioni possono essere causati da una o più delle condizioni seguenti:
- Specifiche del computer insufficienti
- Mancanza del service pack e degli aggiornamenti più recenti per Outlook
- File di cartelle personali di grandi dimensioni (pst) o file di cartelle offline (ost)
- Componenti aggiuntivi di terze parti
- La cartella AppData viene reindirizzata a un percorso di rete
- Integrazione di Microsoft Skype for Business
- Interazione con il software antivirus
- Indicizzazione di Windows Search o Windows Desktop Search
- Chiusura incompleta di file PST o OST
- Molti feed RSS (Really Simple Syndication)
- To-Do Bar e modalità online con Exchange Server
- Profilo di messaggistica di Outlook danneggiato
Avvertenza Molti di questi elementi possono essere controllati automaticamente dall'Assistente supporto tecnico Microsoft (SaRA). Per avviare i controlli automatici, eseguire le operazioni seguenti:
- Installare lo strumento di diagnostica avanzata di Outlook .
- Quando viene richiesto dal browser, fare clic su Esegui .
- Nel report generato esaminare gli elementi nella scheda Problemi rilevati . Per informazioni dettagliate sulla configurazione di Outlook, Windows e del computer, rivedere le impostazioni nella scheda Visualizzazione dettagliata .
Il computer soddisfa i requisiti di sistema per la versione di Office in uso?
Verificare che il computer soddisfi i requisiti di sistema per la versione di Office in uso. Per altre informazioni sui requisiti di sistema per Office, visitare il seguente sito Web Microsoft, in base alla versione di Office in uso:
Per Office 2016 e Office 2013:
Requisiti di sistema per Office
Per Office 2010:
Requisiti di sistema per Office 2010
Se il computer soddisfa solo i requisiti minimi di sistema, le prestazioni di Office non saranno ottimali.
Stai eseguendo l'ultima versione di Outlook?
È consigliabile installare i Service Pack (SP) e i pacchetti hotfix applicabili più recenti. Per ulteriori informazioni sugli aggiornamenti più recenti applicabili, vedere il seguente articolo della Microsoft Knowledge Base:
2625547 Come installare gli aggiornamenti più recenti applicabili per Microsoft Outlook (solo in inglese Stati Uniti)
Si dispone di un file PST o OST di grandi dimensioni?
Se si dispone di un file PST o OST di grandi dimensioni, potrebbero verificarsi pause dell'applicazione durante l'esecuzione di operazioni tipiche in Outlook. Queste operazioni tipiche includono la lettura, lo spostamento e l'eliminazione dei messaggi di posta elettronica.
Quando si usa Outlook, in genere vengono applicate le seguenti linee guida per le dimensioni .ost:
- Fino a 5 gigabyte (GB): queste dimensioni del file dovrebbero fornire una buona esperienza utente sulla maggior parte dell'hardware.
- Tra 5 e 10 GB: queste dimensioni del file dipendono in genere dall'hardware. Pertanto, se hai un disco rigido veloce e molta RAM, la tua esperienza sarà migliore. Tuttavia, le unità disco rigido più lente, ad esempio le unità che si trovano in genere su computer portatili o unità a stato solido (SSD) di prima generazione, riscontrano alcune pause delle applicazioni quando le unità rispondono.
- Più di 10 GB: quando il file OST raggiunge queste dimensioni, iniziano a verificarsi brevi pause nella maggior parte dell'hardware.
- Molto grande (25 GB o superiore): un file OST di queste dimensioni aumenta la frequenza di brevi pause, soprattutto durante il download di nuovi messaggi di posta elettronica. È tuttavia possibile usare i gruppi di invio/ricezione per sincronizzare manualmente la posta elettronica. Per altre informazioni sui gruppi di invio/ricezione, vedere la sezione "Molti feed RSS vengono sincronizzati?".
In Outlook 2010 e versioni successive le dimensioni massime di un file PST sono 50 GB. La dimensione massima predefinita per un file Unicode .pst o .ost è circa 25 GB. Il seguente articolo della Microsoft Knowledge Base descrive come aumentare le dimensioni massime di un file PST o OST:
832925 Come configurare il limite di dimensioni per i file (.pst) e (.ost) in Outlook
Sono presenti molti elementi in un'unica cartella?
Se si usano file OST o PST
Se una singola cartella contiene molti elementi, potrebbero verificarsi problemi di prestazioni durante determinate operazioni in Outlook mentre si usano i file di dati locali. Se si usa Outlook per connettersi a una cassetta postale che si trova in Microsoft Exchange Server e si usa la modalità cache, Outlook sincronizza la posta elettronica e altri elementi in un file OST (Offline Outlook Data). Se si usa Outlook per connettersi ad altri account di posta elettronica, ad esempio POP3 o IMAP, Outlook archivia la posta elettronica e altri elementi in un file di dati di Outlook (PST) locale. Questi problemi di prestazioni sono particolarmente evidenti quando si entra e si esce da cartelle che contengono molti elementi.
Se in Outlook 2010 e versioni successive sono presenti più di 100.000 elementi in una singola cartella, le visualizzazioni diverse da Disponi per: data potrebbero essere più lente. È consigliabile spostare diversi elementi di queste cartelle più grandi in cartelle separate nello stesso archivio o in un archivio e usare Disponi per: data di esecuzione Outlook. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
2768656 problemi di prestazioni in Outlook quando sono presenti troppi elementi o cartelle in una cartella di file OST o PST in modalità cache
Se ci si connette a Exchange in modalità online
Se non si utilizza la modalità cache exchange, è consigliabile esaminare una delle risorse seguenti. Queste risorse documentano alcuni problemi di prestazioni su un server Exchange con un numero elevato di elementi e visualizzazioni limitate. Inoltre, le risorse discutono di come questi problemi di prestazioni potrebbero influire sull'esperienza utente complessiva del client. Per informazioni sull'effetto sulle prestazioni di un numero elevato di elementi e di visualizzazioni limitate, visitare i seguenti siti Web Microsoft:
Informazioni sui fattori di prestazioni di database e log
Sono presenti componenti aggiuntivi non essenziali o non aggiornati installati in Outlook?
Se sono stati installati componenti aggiuntivi non essenziali, è consigliabile rimuoverli da Outlook. Per visualizzare i componenti aggiuntivi installati, procedere come segue:
- In Outlook fare clic sulla scheda File.
- Fare clic su Opzioni e quindi su Componenti aggiuntivi per visualizzare un elenco dei componenti aggiuntivi COM installati.
Per impostazione predefinita, i componenti aggiuntivi COM seguenti sono inclusi in Office 2010:
- Componente aggiuntivo di Microsoft Access per la raccolta e la pubblicazione dei dati
- Componente aggiuntivo di Microsoft Exchange
- Microsoft Outlook Social Connector
- Componente aggiuntivo Microsoft SharePoint Workspace Proxy per Outlook
- Componente aggiuntivo per l'importazione di colleghi di Microsoft Server SharePoint
- Componente aggiuntivo Microsoft VBA per Outlook
- Note di OneNote sugli elementi di Outlook
- Windows Search Email Indexer
Tutti gli altri componenti aggiuntivi elencati nei componenti aggiuntivi COM sono stati installati da altri software.
Per determinare se il problema di prestazioni è causato dai componenti aggiuntivi, eseguire Outlook in modalità provvisoria. A questo scopo, tenere premuto CTRL all'avvio di Outlook. Quando Outlook viene avviato in modalità provvisoria, tutti i componenti aggiuntivi COM e le estensioni client di Exchange Server vengono disabilitati.
Se il problema non si verifica più quando Outlook è in esecuzione in modalità provvisoria, è probabile che il problema di prestazioni sia causato da uno dei componenti aggiuntivi. Per risolvere eventuali problemi causati dai componenti aggiuntivi COM o dalle estensioni client di Exchange Server, disabilitare gli elementi che non si usano regolarmente. Quindi, riavviare Outlook. Se il problema persiste, disabilitare i componenti aggiuntivi rimanenti uno alla volta. Se il problema non si risolve, il problema potrebbe non essere causato da un componente aggiuntivo.
Per disabilitare i componenti aggiuntivi COM, procedere come segue:
- In Outlook fare clic sulla scheda File.
- Fare clic su Opzioni e quindi su Componenti aggiuntivi per visualizzare un elenco dei componenti aggiuntivi COM installati.
- Selezionare Componenti aggiuntivi COM nell'elenco Gestisci e quindi fare clic su Vai.
- Nella finestra di dialogo Componenti aggiuntivi COM fare clic per deselezionare le caselle di controllo relative ai componenti aggiuntivi COM che si desidera disabilitare.
- Fare clic su OK e riavviare Outlook.
La cartella AppData viene reindirizzata a un percorso di rete?
Importante
Seguire attentamente i passaggi descritti in questa sezione. La modifica non corretta del Registro di sistema potrebbe comportare problemi gravi. Prima di iniziare, eseguire il backup del Registro di sistema in modo che sia possibile ripristinarlo in caso di problemi.
Outlook archivia alcuni dati, ad esempio le firme di posta elettronica e il dizionario del correttore ortografico, nella cartella AppData. Se le prestazioni della rete sono lente, Outlook deve attendere il completamento delle operazioni di lettura e scrittura nella directory AppData.
Per disabilitare il reindirizzamento della directory AppData, eseguire le operazioni seguenti:
Uscire da Outlook.
Avvia l'editor del Registro di sistema. A tale scopo, usa una delle procedure seguenti, a seconda della versione di Windows in uso:
- Windows 10, Windows 8.1 e Windows 8: premere il tasto WINDOWS+R per aprire una finestra di dialogo Esegui. Digitare regedit.exee quindi premere OK.
Nell'editor del Registro di sistema individuare e fare clic sulla sottochiave seguente:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
Individuare e quindi fare doppio clic sul valore riportato di seguito:
AppData
Nella casella Dati valore digitare il percorso seguente e quindi fare clic su OK.
%USERPROFILE%\AppData\Roaming
Uscire dall'editor del Registro di sistema.
L'integrazione di Outlook con Skype for Business è abilitata?
Per impostazione predefinita, Outlook include l'integrazione delle funzionalità con Microsoft Skype for Business. Le funzionalità condivise da Outlook e Skype riguardano principalmente le informazioni sulla presenza, ad esempio se un utente è occupato, assente o in riunione. Per disabilitare l'integrazione delle funzionalità, segui questa procedura:
- In Outlook fare clic sulla scheda File e quindi su Opzioni.
- Fare clic su Contatti, quindi sulla casella di controllo Visualizza stato online accanto a un nome in Stato online e fotografie per deselezionarla e quindi fare clic su OK.
- Riavviare Outlook.
Il software antivirus è in esecuzione?
Avviso Questa soluzione alternativa può rendere un computer o una rete più vulnerabile agli attacchi da parte di utenti malintenzionati o di malware, ad esempio virus. Microsoft non consiglia di usare questa soluzione alternativa, ma fornisce queste informazioni per consentire all'utente di implementarla a propria discrezione. Usare questa soluzione alternativa a proprio rischio.
Se il software antivirus include l'integrazione con Outlook, potrebbero verificarsi problemi di prestazioni in Outlook. In questo caso, è possibile disabilitare tutte le integrazioni di Outlook all'interno del software antivirus. In alternativa, è possibile disabilitare i componenti aggiuntivi del software antivirus installati in Outlook. Tenere presente che se ci si connette a una cassetta postale di Exchange Server, la cassetta postale o i messaggi di posta elettronica sono già analizzati dal software antivirus sul server. Verificare con l'amministratore di Exchange che sia così.
Potrebbe essere necessario contattare il produttore dell'antivirus per determinare come configurare il software antivirus in modo da escludere qualsiasi integrazione con Outlook o per escludere l'analisi in Outlook.
Inoltre, se si prevede di eseguire la scansione antivirus a livello di file mentre è in uso Outlook, leggere il seguente articolo di Microsoft TechNet Library.
Pianificare l'analisi antivirus per Outlook 2010
Pianificare l'analisi antivirus per Outlook 2013
Sezione "Considerazioni sulla sicurezza di Outlook" di Considerazioni sulla pianificazione per la distribuzione di Outlook 2016 per Windows
Windows Search o Windows Desktop Search indicizza attualmente i dati nel file PST o OST?
Windows Search nelle versioni di Windows 10 e Windows 8 indicizza tutti i dati nei file OST e PST. Tuttavia, l'indicizzazione dei dati di Outlook viene eseguita solo quando Outlook è in esecuzione. Di conseguenza, potrebbe essere necessario lasciare Outlook acceso durante la notte per determinare se i problemi di prestazioni siano correlati alla creazione degli indici di ricerca.
I problemi di prestazioni possono aumentare quando Outlook è in esecuzione in modalità online. Questi problemi di prestazioni si verificano perché l'esecuzione di Outlook in modalità online aumenta il carico sul server Exchange. Questo problema di prestazioni è particolarmente evidente quando Outlook è configurato in uno stato non predefinito per indicizzare gli elementi dal server Exchange all'indice del client locale e se più utenti indicizzano i dati di Outlook contemporaneamente usando Windows Search o WDS.
Per determinare lo stato di indicizzazione per i dati di Outlook in Outlook, eseguire le operazioni seguenti:
- Fare clic sulla casella di ricerca sopra l'elenco dei messaggi di posta elettronica. La scheda Cerca viene abilitata non appena esegui questa operazione.
- Nella sezione Opzioni fare clic su Strumenti di ricerca, quindi selezionare Stato indicizzazione.
- Nella finestra di dialogo Stato indicizzazione visualizzare il numero di elementi rimanenti da indicizzare.
Il meccanismo di backoff integrato nel componente di indicizzazione di Windows Search o WDS sospende l'indicizzazione dei dati di Outlook quando il sistema è sottoposto a un uso intenso. Il modo più semplice per completare l'indicizzazione consiste nel lasciare Outlook in esecuzione durante la notte.
È inoltre possibile ridurre i problemi di prestazioni eseguendo Outlook in modalità cache. In questa modalità, Windows Search o WDS cerca la copia locale della cassetta postale anziché il contenuto della cassetta postale nel server.
Il file PST o OST è stato arrestato in modo non corretto?
Se il file PST o OST non si arresta correttamente, al successivo avvio di Outlook potrebbe essere visualizzato uno dei messaggi di errore seguenti:
Messaggio di errore 1
Nota
Outlook non riesce ad aprire il file di dati
fino a quando non viene verificata la presenza di problemi.Messaggio di errore 2
Nota
Microsoft Office Outlook' si chiudeva senza chiudere correttamente il file di dati di Outlook 'unità:\Utenti\nomeutente\AppData\Local\Microsoft\Outlook\outlook.ost'. "Microsoft Office Outlook" deve essere riavviato. Se il messaggio di errore è ricorrente, contattare il supporto di "Microsoft Office Outlook" per assistenza.
Messaggio di errore 3
Nota
File di dati
il nome del file non è stato chiuso correttamente". Questo file è in fase di verifica della presenza di problemi.
Se si ricevono uno o più di questi messaggi di errore, potrebbero verificarsi problemi di prestazioni finché Outlook non completa il processo di riconciliazione per il file OST o PST. Nella barra di stato viene visualizzata l'icona a forma di ingranaggio seguente mentre Outlook controlla il file di dati in background:
Quando questa icona non è più disponibile, il file PST o OST è riconciliato. Il processo di riconciliazione viene sospeso all'arresto e riprenderà (dal punto in cui era stato sospeso) al successivo avvio di Outlook.
Un file OST o PST chiuso in modo non corretto può verificarsi per uno dei motivi seguenti:
- Scansione antivirus del file
- Arresto forzato di Microsoft Windows prima dell'arresto completo del processo di Outlook.exe
- Componenti aggiuntivi di Outlook
Se si verifica spesso questo problema ed è necessario chiudere Outlook poco prima di arrestare il computer, potrebbe essere consigliabile arrestare Windows mentre Outlook è ancora in esecuzione. È consigliabile eseguire questa operazione invece di uscire da Outlook e chiudere Windows poco dopo.
Si usa una regola che consente di spostare gli oggetti dal negozio predefinito?
Le regole che spostano gli elementi dall'archivio predefinito a un altro archivio possono causare problemi di prestazioni quando Outlook scarica i messaggi di posta elettronica.
Se si utilizzano le regole per spostare la posta da un account POP3 a un altro archivio, è possibile utilizzare la nuova funzionalità di Outlook 2010 che consente di modificare il luogo di recapito dell'account POP3. In questo caso, non è necessario usare le regole per recapitare la posta da tale account al negozio separato.
A questo scopo, procedere come segue:
- In Outlook fare clic sulla scheda File , fare clic su Informazioni, quindi su Impostazioni account, quindi di nuovo su Impostazioni account e quindi selezionare l'account POP3 nell'elenco.
- Fare clic su Cambia cartella nella parte inferiore della finestra di dialogo Impostazioni account per selezionare una cartella nel negozio separato a cui si desidera distribuire l'account.
Se non si usa un account POP3, è anche possibile risolvere il problema impostando la cartella di destinazione per tutte le regole nello stesso Outlook Store. È quindi possibile usare la funzionalità di archiviazione automatica per spostare i messaggi dall'archivio predefinito in blocco.
Per ulteriori informazioni su come configurare la funzionalità di archiviazione automatica, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
830119 Descrizione della funzionalità di archiviazione automatica in Outlook
Si stanno sincronizzando molti feed RSS?
Se si sincronizzano molti feed RSS in Outlook, potrebbero verificarsi problemi di prestazioni quando si eseguono alcune operazioni ordinarie. Per impostazione predefinita, tutti i feed RSS vengono sincronizzati automaticamente a intervalli predefiniti. Se si dispone di un numero eccessivo di feed, Outlook potrebbe non rispondere.
È possibile creare un gruppo di invio/ricezione distinto contenente solo feed RSS e rimuoverli dal gruppo in cui si trova l'account di posta predefinito. In questo modo è possibile sincronizzare i feed RSS su richiesta anziché a intervalli predefiniti. A questo scopo, procedere come segue:
- Nella sezione Invia e ricevi fare clic sulla scheda File, quindi su Opzioni, su Avanzate e infine su Invia/Ricevi.
- Fare clic sull'opzione Tutti gli account e quindi su Modifica.
- Nel riquadro di spostamento (a sinistra) fare clic su RSS.
- In Opzioni invio/ricezione fare clic per deselezionare le caselle di controllo accanto all'RSS che non si vuole sincronizzare con Outlook e quindi fare clic su OK.
- Fare clic su Nuovo, digitare un nome per il nuovo gruppo e quindi fare clic su OK.
- Fare clic su RSS sul lato sinistro.
- Selezionare i feed RSS per i quali si desidera limitare e quindi fare clic su OK.
Le impostazioni nelle finestre Gruppo di invio/ricezione consentono di personalizzare la velocità di sincronizzazione del nuovo gruppo.
Si esegue Outlook con la barra di To-Do abilitata o con una sbirciatina aggiunta quando Outlook è in esecuzione in modalità online su un server Exchange?
Se si esegue Outlook 2013 o versione successiva con una barra bloccata in alto o Outlook 2010 con la barra di To-Do abilitata quando Outlook è in esecuzione in modalità online su un server Exchange, i dati aggiuntivi visualizzati nella barra di anteprima o nella barra di To-Do vengono recuperati dal server. Di conseguenza, vengono eseguite richieste di dati aggiuntive per la barra di anteprima o la barra di To-Do. Queste richieste di dati aggiuntive causano traffico di rete aggiuntivo che può influire sulle prestazioni di alcune operazioni di Outlook standard.
In Outlook 2010 il traffico di rete causato dalla barra di To-Do è ridotto rispetto alle versioni precedenti, soprattutto quando la barra di To-Do carica elementi del calendario ricorrenti.
Per evitare l'aumento del traffico di rete e l'effetto sulle prestazioni di Outlook che ne deriva, è possibile rimuovere la visualizzazione o disattivare la barra di To-Do e quindi ridurre il traffico di rete tra Outlook ed Exchange in modalità online. Questa riduzione delle richieste di recupero dei dati influisce in modo più significativo sull'esperienza utente se si dispone di una rete con latenza elevata o larghezza di banda limitata.
Per rimuovere la Anteprima rapida o disattivare la barra To-Do in Outlook, scegliere To-Do barranel menu Visualizza e quindi fare clic su Off.
Importante
Seguire attentamente i passaggi descritti in questa sezione. La modifica non corretta del Registro di sistema potrebbe comportare problemi gravi. Prima di iniziare, eseguire il backup del Registro di sistema in modo che sia possibile ripristinarlo in caso di problemi.
Gli amministratori possono disabilitare la barra To-Do nei computer degli utenti che eseguono Outlook 2010 utilizzando le informazioni del Registro di sistema seguenti.
Se non si utilizza un'impostazione di criterio, utilizzare le informazioni seguenti.
Posizione del Registro di sistema:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\14.0\Outlook\Options\ToDoBar
- oppure -
HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Office\14.0\Outlook\Options\ToDoBar
Nome valore: DisableToDoBar
Tipo valore: DWORD
Dati valore: 1 o 0
Avvertenza Se il valore è impostato su 1, la barra di To-Do è disattivata. Se il valore è impostato su 0, la barra di To-Do è attivata.
Per altre informazioni su come gli amministratori possono controllare l'interfaccia utente tramite le impostazioni dei criteri, visitare i seguenti siti Web Microsoft:
Configurare le impostazioni utente per Office 2010
Gestire le configurazioni degli utenti per Office 2010
Si è provato a creare un nuovo profilo di Outlook?
In alcuni casi, un profilo di messaggistica di Outlook potrebbe non essere configurato correttamente. La creazione di un nuovo profilo Outlook può risolvere alcuni problemi di prestazioni.
I prodotti di terze parti descritti in questo articolo sono realizzati da società indipendenti da Microsoft. Microsoft non fornisce garanzie, implicita o di altro tipo, in merito alle prestazioni o all'affidabilità di questi prodotti.
Microsoft fornisce informazioni di contatto di terze parti per aiutarti a trovare il supporto tecnico. Le informazioni di contatto sono soggette a modifica senza preavviso. Microsoft non garantisce l'accuratezza di queste informazioni di contatto di terze parti.
Per informazioni su come contattare le società menzionate in questo articolo, visitare il seguente sito Web Microsoft: