Riepilogo
Questo articolo spiega come usare la caratteristica Stampa unione in Microsoft Word per creare e stampare lettere usando i dati di un foglio di lavoro di Microsoft Excel.
Quando si usa la caratteristica Stampa unione di Word, Word unisce un documento principale con un elenco di destinatari per generare una serie di documenti di output:
Il documento principale contiene il testo di base che è lo stesso in tutti i documenti di output. Può contenere carta intestata, testo e istruzioni in campi unione per l'inserimento di testo (ad esempio nomi e indirizzi dei destinatari) che variano a seconda del documento di output.
L'elenco dei destinatari è un database che contiene i dati che devono essere uniti ai documenti di output. Ad esempio, l'elenco dei destinatari è un file di database di Microsoft Access o un foglio di lavoro di Excel.
Questo database è in genere un elenco di nomi, indirizzi, numeri di telefono e altre categorie di informazioni personali.
I documenti di output sono il risultato della stampa unione. Il testo in un documento di output può essere lo stesso in tutti i documenti di output, ma è possibile applicare la formattazione a documenti specifici.
Passaggio 1: Configurare il file di dati di Excel
Prima di eseguire la Creazione guidata Stampa unione, verificare che il foglio di lavoro di Excel sia ben strutturato a tale scopo. Per la tabella dati si notano i requisiti seguenti:
- La prima riga deve contenere i nomi dei campi di ogni colonna, ad esempio Titolo, Saluto, Nome, Secondo nome, Cognome, Indirizzo1 e Indirizzo2.
- Ogni nome di campo deve essere univoco.
- Ogni riga deve contenere informazioni su un elemento specifico. Ad esempio, in una lista di distribuzione, ogni riga potrebbe includere informazioni su un destinatario specifico.
- La tabella non deve contenere righe vuote.
Creare il file di dati di Excel e quindi organizzarlo usando i campi da usare per la lettera, come illustrato nel seguente file di dati di esempio.
Dopo aver creato il file di dati di Excel, salvarlo e quindi chiuderlo.
Per ulteriori informazioni su come creare un elenco di indirizzi per la stampa unione, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
294688 Come progettare e configurare un elenco di indirizzi per la stampa unione in Word 2002 e nelle versioni successive di Word
Passaggio 2: Configurare il documento principale
In Microsoft Office Word 2003 e nelle versioni precedenti di Word, scegliere Lettere e lettere dal menu Strumenti e quindi fare clic su Creazione guidata Stampa unione.
In Microsoft Office Word 2007 fare clic su Inizia stampa unione nel gruppo Inizia stampa unione nella scheda Lettere e quindi fare clic su Istruzioni per la Creazione guidata Stampa unione.
In Seleziona tipo di documento fare clic su Lettere.
Il documento attivo diventa il documento principale. Il documento principale contiene il testo e la grafica che sono gli stessi per ogni versione del documento unito. Ad esempio, l'indirizzo del mittente e il saluto in una lettera del modulo sono gli stessi per ogni versione.
Fare clic su Avanti: Documento iniziale.
Usare uno dei metodi seguenti:
Inizia con il documento attualmente visualizzato nella finestra del documento. A tale scopo, fare clic su Usa il documento corrente.
È quindi possibile digitare la lettera nella finestra del documento o attendere che la procedura guidata richieda di eseguire questa operazione in un passaggio successivo.
Iniziare con un modello. A questo scopo, procedere come segue:
Fare clic su Inizia da un modello.
Fare clic su Seleziona modello.
Nella scheda Stampa unione selezionare il modello desiderato nella finestra di dialogo Seleziona modello e quindi fare clic su OK.
Inizia con un documento esistente. A questo scopo, procedere come segue:
- Fare clic su Avvia da documento esistente.
- Nella casella Inizia da esistente selezionare il documento desiderato e quindi fare clic su Apri.
- Se il documento non è visibile, fare clic su Altri file e quindi su Apri. Nella finestra di dialogo Apri individuare il documento desiderato e quindi fare clic su Apri.
Fare clic su Successivo: Selezione dei destinatari.
Passaggio 3: Specificare l'origine dati di Excel
In Seleziona destinatari fare clic su Utilizza un elenco esistente.
Fare clic su Sfoglia.
Nella finestra di dialogo Seleziona origine dati individuare e fare clic sul foglio di lavoro di Excel da usare.
Per impostazione predefinita, Word apre la cartella "Origini dati personali".
Fare clic su Apri.
Se il foglio di lavoro di Excel contiene informazioni su più schede, selezionare la scheda che contiene le informazioni desiderate e quindi fare clic su OK.
Tutte le voci dell'origine dati vengono visualizzate nella finestra di dialogo Destinatari Stampa unione. Qui è possibile perfezionare l'elenco dei destinatari da includere nell'unione.
Passaggio 4: Selezionare i destinatari
Nella finestra di dialogo Destinatari Stampa unione selezionare i destinatari da includere. A tale scopo, utilizzare uno dei metodi seguenti:
Usare le caselle di controllo per designare i destinatari.
È consigliabile usare questo metodo se l'elenco è breve. Fare clic per selezionare le caselle di controllo accanto ai destinatari che si desidera includere e quindi fare clic per deselezionare le caselle di controllo accanto ai destinatari da escludere.
Nota: se si desidera includere la maggior parte dell'elenco nell'unione, fare clic su Seleziona tutto e quindi fare clic per cancellare determinati record. Analogamente, se si desidera includere solo alcuni record nell'elenco, fare clic su Cancella tutto e quindi selezionare i record desiderati.
Ordinare gli elementi nell'elenco.
Questo metodo è utile se si desidera visualizzare gli elementi in ordine alfabetico o numerico. Fare clic sull'intestazione di colonna dell'elemento in base al quale si desidera ordinare. Ad esempio, per visualizzare l'elenco in ordine alfabetico per cognome, fare clic sull'intestazione di colonna Cognome.
Filtrare gli elementi nell'elenco.
Questo metodo è utile se l'elenco contiene record che non si desidera visualizzare o includere nell'unione. Dopo aver filtrato l'elenco, è possibile utilizzare le caselle di controllo per includere ed escludere record, come descritto in precedenza. Per filtrare l'elenco, attenersi alla seguente procedura:
Fare clic sulla freccia accanto all'intestazione di colonna dell'elemento in base a cui filtrare.
Fare clic su una delle opzioni seguenti:
- (Vuote): questa opzione visualizza tutti i record in cui il campo corrispondente è vuoto.
- (Non vuote): questa opzione visualizza tutti i record in cui il campo corrispondente contiene informazioni.
- Se l'origine dati contiene record che condividono le stesse informazioni e se nella colonna sono presenti 10 o meno valori univoci, è possibile applicare un filtro in base a informazioni specifiche. Se ad esempio sono presenti più indirizzi nell'elenco Australia come paese, è possibile filtrare in base all'Australia.
Nella finestra di dialogo Destinatari Stampa unione verranno visualizzati solo i record corrispondenti. Per visualizzare di nuovo tutti i record, fare clic su (Tutto).
Note
- Per le opzioni di ordinamento e filtro avanzate, fare clic sulla freccia accanto al nome di una colonna, quindi fare clic su (Avanzate). Utilizzare le schede Filtra record e Ordina record per configurare la query di ordinamento o filtro desiderata.
- Se è stato installato un software di convalida degli indirizzi, fare clic su Convalida nella finestra di dialogo Destinatari Stampa unione per convalidare gli indirizzi dei destinatari.
Fare clic su OK per tornare alla Creazione guidata Stampa unione.
Word usa i destinatari designati per l'unione.
Fai clic su Avanti: Scrivi la tua lettera.
Passaggio 5: Completa la lettera e aggiungi i campi unione
Se non è già stato fatto, digitare il testo da visualizzare in ogni lettera del documento principale.
Inserisci campi unione
Inserire i campi unione in cui si vogliono unire nomi, indirizzi e altre informazioni dell'origine dati. Per inserire campi unione, attenersi alla seguente procedura:
Nel documento principale fare clic nel punto in cui si vuole inserire il campo.
Inserire uno degli elementi seguenti:
Blocco indirizzo con nome, indirizzo e altri dati:
Fare clic su Blocco di indirizzi.
Nella finestra di dialogo Inserisci blocco di indirizzi selezionare gli elementi dell'indirizzo da includere e i formati da applicare, quindi fare clic su OK. Per informazioni su un'opzione, fare clic sul punto interrogativo e quindi sull'opzione.
Per informazioni su un'opzione, fare clic sul punto interrogativo e quindi sull'opzione. Se viene visualizzata la finestra di dialogo Corrispondenza campi, Word potrebbe non essere in grado di trovare alcune delle informazioni necessarie per il blocco di indirizzi. Fare clic sulla freccia accanto a
(non disponibile) e quindi selezionare il campo dall'origine dati corrispondente al campo necessario per la stampa unione.
Formula di saluto:
Fare clic su Formula di apertura.
Selezionare il formato della formula di apertura che include il saluto, il formato del nome e la punteggiatura successiva.
Selezionare il testo da visualizzare nei casi in cui Word non è in grado di interpretare il nome del destinatario. Ad esempio, Word non è in grado di interpretare il nome quando l'origine dati non contiene il nome o il cognome di un destinatario, ma solo il nome di una società.
Fare clic su OK.
Se viene visualizzata la finestra di dialogo Corrispondenza campi, Word potrebbe non essere in grado di trovare alcune delle informazioni necessarie per la formula di apertura. Fare clic sulla freccia accanto a (non disponibile) e quindi selezionare il campo dell'origine dati corrispondente al campo necessario per la stampa unione.
Altri campi d'informazione:
Fai clic su Altri elementi.
Usare uno dei metodi seguenti:
- Fare clic su Campi indirizzo per selezionare uno dei campi indirizzo che verranno automaticamente mappati ai campi corrispondenti nell'origine dati, anche se i campi dell'origine dati non hanno lo stesso nome dei campi.
- Fare clic su Campi database per selezionare uno dei campi che accettano sempre dati direttamente da una colonna in un database.
Nella casella Campi fare clic sul campo desiderato.
Fare clic su Inserisci e quindi su Chiudi.
Se viene visualizzata la finestra di dialogo Corrispondenza campi, Word potrebbe non essere in grado di trovare alcune delle informazioni necessarie per inserire il campo. Fare clic sulla freccia accanto a (non disponibile) e quindi selezionare il campo dell'origine dati corrispondente al campo necessario per la stampa unione.
Nota Se si inserisce un campo dall'elenco Campi database e si passa in seguito a un'origine dati che non contiene una colonna con lo stesso nome, Word non può inserire tali informazioni sul campo nel documento unito.
Affrancatura elettronica:
Per aggiungere la spedizione elettronica, è necessario installare prima un programma di affrancatura elettronica, ad esempio un programma che sia possibile acquistare da un provider di terze parti sul Web. Per utilizzare l'affrancatura elettronica, attenersi alla seguente procedura:
Fare clic su Spedizione elettronica.
Se non si dispone di un programma di affrancatura elettronica, Word chiede di installarne uno e offre la connessione al seguente sito Web di Microsoft Office:
Affrancatura online stampata
http://office.microsoft.com/services/service.aspx?sid=2.4Inserire l'affrancatura secondo le istruzioni del programma.
Per aggiungere la spedizione elettronica, è necessario installare prima un programma di affrancatura elettronica, ad esempio un programma che sia possibile acquistare da un provider di terze parti sul Web. Per utilizzare l'affrancatura elettronica, attenersi alla seguente procedura:Codice a barre postale: è necessario selezionare un tipo di lettera o busta che supporti il codice a barre POSTNET. Per usare il codice a barre postale, attenersi alla seguente procedura:
Fare clic su Codice a barre postali.
Nella finestra di dialogo Inserisci codice postale selezionare i campi indirizzo appropriati.
Nota: l'opzione Codice a barre postale viene visualizzata solo se si usa la versione di Word in lingua americana.
Ripetere i passaggi a e b per tutti i campi che si desidera inserire. NOTE:
- Non è possibile digitare caratteri di campo unione (" ") o inserirli usando il comando Simbolo nel menu Inserisci.
- Se i campi unione sono visualizzati tra parentesi graffe, ad esempio { MERGEFIELD Città }, Word visualizza i codici di campo invece dei risultati del campo. Ciò non influisce sull'unione, ma se si vogliono visualizzare i risultati, fare clic con il pulsante destro del mouse sul codice di campo e quindi scegliere Attiva/disattiva codici di campo dal menu di scelta rapida.
Ad esempio, usando il database di esempio illustrato in precedenza, la lettera potrebbe contenere i campi AddressBlock e GreetingLine e quindi la prima pagina appare simile alla seguente:
26 febbraio 2002Blocco di indirizzi
GreetingLine
Digita qui la tua lettera.
Cordiali saluti,
Digita qui il tuo nome
Nota: è anche possibile usare la barra degli strumenti Stampa unione per inserire campi unione, usare il documento principale di stampa unione o eseguire una stampa unione. Per visualizzare la barra degli strumenti Stampa unione, scegliere Lettere e lettere dal menu Strumenti e quindi fare clic su Mostra barra degli strumenti Stampa unione.
La barra degli strumenti Stampa unione include comandi aggiuntivi che non sono inclusi nei riquadri attività Stampa unione. Ad esempio, è possibile usare il menu Inserisci campo di Word sulla barra degli strumenti Stampa unione per inserire campi di Word per controllare il processo di unione. Ad esempio, è possibile inserire un campo IF che inserisce testo solo se un determinato campo unione ha un valore specificato.
In alternativa, fare clic su Controlla errori per fare in modo che Word esegua la stampa unione e segnali gli eventuali errori contenuti nel documento principale.
Modificare il formato dei dati uniti
Per formattare i dati uniti, è necessario formattare i campi unione nel documento principale. Non formattare i dati nell'origine dati perché la formattazione non viene mantenuta quando si uniscono i dati al documento. Per modificare il formato dei dati uniti, eseguire le operazioni seguenti:
Nel documento principale selezionare il campo contenente le informazioni da formattare, inclusi i caratteri del campo unione (<<>>).
In Word 2003 e nelle versioni precedenti di Word, scegliere Carattere dal menu Formato e quindi selezionare le opzioni desiderate.
In Word 2007 fare clic sull'opzione desiderata nella casella Tipi di carattere tema nel gruppo Carattere della scheda Home.
Formattare usando i codici di campo
Per controllare altri aspetti della formattazione, premere ALT+F9 per visualizzare i codici di campo e quindi aggiungere opzioni ai campi unione. Quando si usano i campi, un parametro è un'istruzione speciale che provoca l'esecuzione di un'azione specifica. In genere viene aggiunto un parametro a un campo per modificare un risultato.
Di seguito sono riportati alcuni esempi di utilizzo delle opzioni:
- Per visualizzare il numero 34987,89 come $ 34.987,89, aggiungere il parametro Immagine numerica (\#).
- Per stampare i nomi dei client in lettere maiuscole, aggiungere il parametro di formattazione (\*).
- Per assicurarsi che le informazioni unite abbiano lo stesso tipo di carattere e le stesse dimensioni in punti applicate al campo unione, aggiungere il parametro Charformat (\*).
Passaggio 6: Salvare il documento
Dopo aver completato il documento principale e inserito tutti i campi unione, assicurarsi di salvare il documento prima di procedere. A questo scopo, procedere come segue:
In Word 2003 e nelle versioni precedenti di Word, fare clic su Salva con nome dal menu File.
In Word 2007 fare clic sul pulsante Microsoft Office e quindi su Salva con nome.
Assegna un nome al documento e quindi fai clic su Salva.
Fare clic su Avanti: Visualizza l'anteprima delle lettere.
Passaggio 7: Visualizzare in anteprima le lettere e Fine-Tune'elenco dei destinatari
Quando visualizza il riquadro attività "Passaggio 5 Stampa unione", la procedura guidata sostituisce ognuno dei campi unione nel documento principale che contiene il testo effettivo della prima voce dell'elenco dei destinatari. Pertanto, è possibile vedere come apparirà il primo documento di output.
Ad esempio, se si continua a usare il database di esempio illustrato in precedenza, la prima pagina dovrebbe essere simile alla pagina seguente dopo aver fatto clic su Avanti: Visualizzare l'anteprima delle lettere:
26 febbraio 2002
Andrew Fuller
908 W. Capital Way
Tacoma 98401
Caro Andrew Fuller,
Digita qui la tua lettera.
Cordiali saluti,
Digita il tuo nome qui Per visualizzare in anteprima altre voci, usa uno dei metodi seguenti:
- Per visualizzare in anteprima gli elementi in ordine, fare clic sui pulsanti freccia sinistra o destra.
- Per individuare e visualizzare in anteprima un elemento specifico, fare clic su Trova un destinatario e quindi immettere i criteri di ricerca nella finestra di dialogo Trova voce.
Se si vuole, ottimizzare l'elenco dei destinatari. A tale scopo, utilizzare uno dei metodi seguenti:
- Per escludere un particolare destinatario dall'operazione di unione, fare clic su Escludi questo destinatario.
- Per modificare l'elenco di destinatari, fare clic su Modifica elenco destinatari, quindi apportare le modifiche nella finestra di dialogo Destinatari Stampa unione.
Passaggio 8: completare l'unione
Per completare l'unione, utilizzare uno dei metodi seguenti.
Personalizza singole lettere
Per personalizzare singoli elementi, è necessario completare effettivamente l'unione e quindi modificare le informazioni desiderate nel documento unito risultante. A questo scopo, procedere come segue:
Fai clic su Edit individual letters.
Nella finestra di dialogo Unisci a nuovo documento selezionare i record da unire.
Fare clic su OK.
Word crea e apre un nuovo documento unito. Anche il documento principale rimane aperto ed è possibile tornarvi se si vogliono modificare tutti i documenti.
Scorrere fino alle informazioni che si desidera modificare e quindi apportare le modifiche.
Stampa o salva il documento come faresti con qualsiasi documento normale.
Stampare le lettere
Per stampare le lettere, usare uno dei metodi seguenti:
Se gli elementi sono stati personalizzati e il documento unito è attivo, seguire questa procedura:
In Word 2003 e nelle versioni precedenti di Word, scegliere Stampa dal menu File.
In Word 2007 fare clic sul pulsante Microsoft Office e quindi su Stampa.
Selezionare le opzioni desiderate.
Se si vuole stampare direttamente dalla Creazione guidata Stampa unione, seguire questa procedura:
Nel passaggio 6 della Creazione guidata Stampa unione (Completare l'unione), fare clic su Stampa.
Nella finestra di dialogo Unisci alla stampante utilizzare uno dei metodi seguenti e quindi fare clic su OK:
- Per stampare tutti i documenti, fare clic su Tutti.
- Per stampare il documento visualizzato nella finestra del documento, fare clic su Record corrente.
- Per stampare un intervallo di documenti, fare clic su Da, quindi digitare i numeri di record nelle caselle Da e A.
Nella finestra di dialogo Stampa selezionare le opzioni desiderate.
Salvare le lettere unite per un uso successivo
Se si vogliono modificare le lettere unite o salvarle per un uso successivo, è possibile raccoglierle in un unico documento. A questo scopo, procedere come segue:
Fai clic su Edit individual letters.
Nella finestra di dialogo Unisci in un nuovo documento utilizzare uno dei metodi seguenti e quindi fare clic su OK:
- Per unire tutti i documenti, fare clic su Tutti.
- Per unire solo il documento visualizzato nella finestra del documento, fare clic su Record corrente.
- Per unire un intervallo di documenti, fare clic su Da, quindi digitare i numeri di record nelle caselle Da e A.
Word apre un unico nuovo documento contenente tutte le singole lettere. È quindi possibile salvare il documento per un uso successivo, proprio come si farebbe con qualsiasi documento normale.
Riferimenti
Per ulteriori informazioni, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
318117 Come usare gli indirizzi di un foglio di lavoro di Excel per creare etichette in Word
318115 Come creare una lettera utilizzando le informazioni contenute in un database di Access in Word 2002
318112 Come utilizzare gli indirizzi di un database di Access 2002 per creare etichette in Word 2002
294686 Come utilizzare la stampa unione per creare un elenco ordinato per categoria in Word 2002 e versioni successive di Word
290408 Domande frequenti sulla stampa unione in Word 2002
294688 Come progettare e configurare un elenco di indirizzi per la stampa unione in Word 2002 e nelle versioni successive di Word
294693 Come utilizzare la stampa unione per creare una directory in Word 2002 e versioni successive di Word
294683 Come usare la stampa unione per creare lettere in Word 2002 e nelle versioni successive di Word