Messaggio di errore "Messaggio di sistema 5045" in varie posizioni in Microsoft Dynamics SL
Questo articolo fornisce una soluzione a un errore che si verifica in diverse posizioni in Microsoft Dynamics SL.
Si applica a: Microsoft Dynamics SL
Numero KB originale: 875699
Sintomi
Si considerino gli scenari seguenti in varie posizioni in Microsoft Dynamics SL.
- Si tenta di accedere a Microsoft Dynamics SL. Vedere Causa 1, 2 o 3.
- In alternativa, si esegue qualsiasi azione che crea un registro eventi di Microsoft Dynamics SL. Vedere tutte le cause.
- In alternativa, selezionare Avvia nella schermata Controllo integrità fisica del database (95.500.00). Vedere Causa 5.
In questi scenari viene visualizzato il messaggio di errore seguente:
Messaggio di sistema 5045 - Errore del file durante il tentativo di apertura del file di stato del processo
Causa
Questo problema si verifica per uno o più dei motivi seguenti.
Causa 1
L'ID utente di Windows non dispone di autorizzazioni sufficienti per l'operazione. Vedere Risoluzione 1.
Causa 2
L'unità logica mappata all'installazione di Microsoft Dynamics SL non è corretta. Vedere Risoluzione 2.
Causa 3
Il file Solomon.ini nel computer della workstation è danneggiato. Vedere Risoluzione 3.
Causa 4
I file del registro eventi sono danneggiati. Vedere Risoluzione 4.
Causa 5
La tabella PSTATUS è danneggiata. Vedere Risoluzione 5.
Risoluzione
Per risolvere il problema, usare la risoluzione appropriata.
Risoluzione 1
Assegnare le autorizzazioni appropriate agli utenti di Microsoft Dynamics SL.
- Contattare l'amministratore di rete per verificare che l'ID utente di Windows disponga di autorizzazioni sufficienti.
- Assicurarsi che tutti gli utenti di Microsoft Dynamics SL abbiano il controllo completo sulla directory in cui è stato installato Microsoft Dynamics SL. Il percorso predefinito dell'installazione è il seguente:
- Microsoft Dynamics SL 7.0 e versioni successive:
DriveLetter:\Program Files\Microsoft Dynamics\SL\Applications
- Microsoft Dynamics SL 6.5 e versioni precedenti:
DriveLetter:\Program Files\Solomon\
- Microsoft Dynamics SL 7.0 e versioni successive:
Risoluzione 2
Condividere e mappare correttamente l'unità a . Il percorso predefinito dell'installazione di Microsoft Dynamics SL è il seguente:
- Microsoft Dynamics SL 7.0 e versioni successive:
DriveLetter:\Program Files\Microsoft Dynamics\SL\Applications
- Microsoft Dynamics SL 6.5 e versioni precedenti:
DriveLetter:\Program Files\Solomon
In questo caso, le unità dei computer workstation devono essere mappate alla radice del volume o a una delle posizioni seguenti, a seconda della versione:
- Microsoft Dynamics SL 7.0 e versioni successive:
DriveLetter:\Program Files\Microsoft Dynamics SL\
- Microsoft Dynamics SL 6.5 e versioni precedenti:
DriveLetter:\Program Files\
Significa che la radice del volume o una delle posizioni descritte in precedenza deve essere condivisa. Dai computer della workstation, le proprietà dell'icona per il programma principale devono essere le seguenti:
- Microsoft Dynamics SL 7.0 e versioni successive:
DriveLetter:\SL\Applications\MSDynamicsSL.exe
oDriveLetter:\Applications\MSDynamicsSL.exe
- Microsoft Dynamics SL 6.5 o versioni precedenti:
DriveLetter:\Program Files\Solomon\Parent.exe
oDriveLetter:\Solomon\Parent.exe
Nota
Le proprietà dell'icona non devono essere una delle posizioni seguenti (che indica una radice della mappa):
- Microsoft Dynamics SL 7.0 e versioni successive:
DriveLetter:\MSDynamicsSL.exe
- Microsoft Dynamics SL 6.5 e versioni precedenti:
DriveLetter:\Parent.exe
Le proprietà Icon non devono essere una delle posizioni seguenti (che indica un percorso UNC):
- Microsoft Dynamics SL 7.0 e versioni successive:
\\Servername\sharename\Applications\MSDynamicsSL.exe
- Microsoft Dynamics SL 6.5 e versioni precedenti:
\\Servername\sharename\Solomon\Parent.exe
I percorsi UNC non sono supportati in Microsoft Dynamics SL o Microsoft Business Solutions - Solomon.
Risoluzione 3
Rinominare tutti i file Solomon.ini nel computer della workstation in Solomon.old.
Risoluzione 4
Eliminare tutti i file del registro eventi nei percorsi seguenti:
- Microsoft Dynamics SL 7.0 e versioni successive:
DriveLetter:\Program Files\Microsoft Dynamics\SL\Applications\Eventlog\
- Microsoft Dynamics SL 6.5 e versioni precedenti:
DriveLetter:\Program Files\Solomon\Eventlog\
Risoluzione 5
Eliminare i record danneggiati nella tabella PSTATUS.
Nota
Prima di seguire le istruzioni in questo articolo, assicurarsi di disporre di una copia di backup completa del database che è possibile ripristinare in caso di problemi.
Usando SQL Server Management Studio o SQL Query Analyzer, eseguire l'istruzione seguente nel database dell'applicazione Microsoft Dynamics SL o nel database dell'applicazione Microsoft Business Solutions - Solomon:
Delete from PSTATUS