Errore del motore di stampa Crystal 709 Impossibile trovare la tabella quando si esegue un report Crystal Reports personalizzato

Questo articolo fornisce soluzioni per il problema che potrebbe essere visualizzato Errore impossibile trovare la tabella durante l'esecuzione di un report Crystal Reports personalizzato in Microsoft Dynamics SL 2011.

Si applica a: Microsoft Dynamics SL 2011
Numero KB originale: 939712

Sintomi

Considerare lo scenario descritto di seguito:

  • Si esegue Microsoft Dynamics SL 2011.
  • Si usa un report Crystal Reports personalizzato.
  • L'accesso viene eseguito usando l'autenticazione di Windows.

In questo caso, viene visualizzato il seguente messaggio di errore:

Crystal Reports Helper Application for Solomon IV
Get SQL Query failed Report: C:\Program Files\Microsoft Dynamics SL\Usr_Rpts\03730DET. RPT
Errore del motore di stampa Crystal: 709 - Errore nel file C:\Programmi\Microsoft Dynamics SL\Usr_Rpts\03730DET. RPT:

Impossibile trovare la tabella.

Causa 1

Questo errore si verifica perché si verificano le condizioni seguenti:

  • Il report Crystal Reports usa una o più tabelle personalizzate o viste personalizzate.
  • Il E7F575915A2E4897A517779C0DD7CE utente di Microsoft SQL Server o il ruolo applicazione MSDSL SQL Server non dispone delle autorizzazioni necessarie per la tabella personalizzata o per la visualizzazione personalizzata. Vedere Risoluzione 1 nella sezione Risoluzione.

Causa 2

Una connessione ODBC (Open Database Connectivity) viene configurata in modo non corretto per l'uso dell'autenticazione di Windows anziché dell'autenticazione SQL Server. Quando si esegue per la prima volta un report di Crystal Reports in una nuova workstation, viene creata una connessione ODBC per il database di sistema di Microsoft Dynamics SL e per il database dell'applicazione Microsoft Dynamics SL. Questa connessione deve essere configurata per l'uso dell'autenticazione SQL Server, anche se si usa l'autenticazione di Windows per accedere a Microsoft Dynamics SL. Vedere Risoluzione 2 nella sezione Risoluzione.

Risoluzione 1

Assegnare i diritti appropriati alla tabella personalizzata o alla visualizzazione personalizzata. A tal fine, attenersi alla seguente procedura:

  1. Avviare Microsoft SQL Server Management Studio.
  2. Espandere Database, espandere il database di Microsoft Dynamics SL e quindi tabelle o viste.
  3. Individuare la tabella personalizzata o la visualizzazione personalizzata nell'elenco.
  4. Fare clic con il pulsante destro del mouse sulla tabella personalizzata o sulla visualizzazione personalizzata. Selezionare quindi Proprietà.
  5. Nel riquadro Selezionare una pagina selezionare Autorizzazioni.
  6. Selezionare AGGIUNGI, digitare MSDSL e quindi selezionare OK.
  7. Per l'autorizzazione Seleziona selezionare la casella di controllo Concedi .
  8. Selezionare AGGIUNGI.
  9. Selezionare Sfoglia. Selezionare quindi la casella di controllo accanto all'utente E7F575915A2E4897A517779C0DD7CE .
  10. Selezionare due volte OK.
  11. Per l'autorizzazione Controllo selezionare la casella di controllo Concedi .

Risoluzione 2

Per risolvere questo problema, eliminare le connessioni ODBC e consentire a Microsoft Dynamics SL di ricreare le connessioni. A tal fine, attenersi alla seguente procedura:

  1. Selezionare Start, selezionare Impostazioni e quindi selezionare Pannello di controllo.
  2. Selezionare Strumenti di amministrazione.
  3. Selezionare Origini dati (ODBC).
  4. Nella scheda DSN utente rimuovere tutte le voci per il database di sistema di Microsoft Dynamics SL e per il database dell'applicazione Microsoft Dynamics SL.
  5. Nella scheda DSN di sistema rimuovere tutte le voci per il database di sistema di Microsoft Dynamics SL e per il database dell'applicazione Microsoft Dynamics SL.
  6. Accedere di nuovo a Microsoft Dynamics SL e quindi provare a usare di nuovo il report. Le voci DSN utente devono essere ricreate automaticamente.