Durante l'invio del messaggio di posta elettronica viene visualizzato un errore sconosciuto durante il test e l'abilitazione di una cassetta postale in Microsoft Dynamics 365

Questo articolo fornisce una soluzione a un errore che si verifica quando si prova a testare e abilitare una cassetta postale in Microsoft Dynamics 365.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4092733

Sintomi

Quando si tenta di testare e abilitare una cassetta postale in Microsoft Dynamics 365, viene visualizzato l'errore seguente:

"Si è verificato un errore sconosciuto durante l'invio del messaggio di posta elettronica "La cassetta postale è ora connessa a Dynamics 365". Il nome> della cassetta postale <non è stato sincronizzato. Il proprietario del profilo del server di posta elettronica associato Nome> profilo <è stato informato."

Se si seleziona la sezione Dettagli , è anche possibile visualizzare altri dettagli, ad esempio il testo seguente:

"Error : System.Net.Mail.SmtpException: Syntax error, command unrecognized. La risposta del server è stata:
in System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End(IAsyncResult result)
in System.Net.Mail.SmtpTransport.EndGetConnection(IAsyncResult result)
in System.Net.Mail.SmtpClient.ConnectCallback(IAsyncResult result)"

Causa

Questo errore può verificarsi se il valore porta in uscita all'interno della sezione Avanzate del profilo del server di posta elettronica non è corretto.

Risoluzione

Per correggere il problema, attenersi alla procedura seguente:

  1. Passare a Impostazioni, Email Configurazione e quindi selezionare Email Profili server.

  2. Aprire il profilo del server Email usato dalla cassetta postale che soddisfa questo errore.

    Nota

    È anche possibile selezionare il nome del Email Profilo server all'interno del messaggio di errore. Viene visualizzato come collegamento ipertestuale che aprirà il record del profilo del server Email corretto.

  3. Selezionare Avanzate.

  4. Correggere il valore Porta in uscita e quindi selezionare Salva.

    Nota

    Fare riferimento alla documentazione del provider di posta elettronica per le porte corrette da usare per la connessione al servizio SMTP. Per Gmail la porta è 587.

  5. Selezionare Cassette postali e quindi selezionare la cassetta postale che ha ricevuto l'errore.

  6. Selezionare il pulsante Test & Abilita cassette postali .

  7. Al termine dei test, aprire il record della cassetta postale e visualizzare la sezione Avvisi se i risultati non vengono visualizzati come Esito positivo.