Errore "Riferimento a un oggetto non impostato su un'istanza di un oggetto" si verifica quando la configurazione di Microsoft Dynamics CRM per Outlook

Sintomi

Durante la configurazione di Microsoft Dynamics CRM 2011 o 2013 CRM per Outlook a un'istanza di Microsoft Dynamics CRM Online, si verifica un errore "Riferimento di oggetto non impostato su un'istanza di un oggetto" dopo immettere le credenziali, la scelta dell'organizzazione e facendo clic su OK:


È un problema di comunicazione con il server Microsoft Dynamics CRM. Il server potrebbe non essere disponibile. Riprovare più tardi. Se il problema persiste, contattare l'amministratore di sistema.


Riferimento all'oggetto non impostato a un'istanza di un oggetto.


in Microsoft.Crm.Passport.IdCrl.OnlineServicesFederationLogOnManager.GetBrowserClientAuthInfo (stringa redirectEndpoint, partner di stringa, criteri di stringhe, stringhe e postData)


in Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.SignIn()


in Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.SignIn (Uri endPoint, credenziali credenziali, UI AuthUIMode, IClientOrganizationContext contesto, modulo parentWindow, Boolean retryOnError)


in Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.GetAuthProvider (Uri endPoint, credenziali credenziali, UI AuthUIMode, webEndPoint di Uri, contesto IClientOrganizationContext, parentWindow modulo)


in Microsoft.Crm.Application.Outlook.Config.ServerInfo.LoadUserId()


in Microsoft.Crm.Application.Outlook.Config.ServerInfo.Initialize (Uri discoveryUri, OrganizationDetail selectedOrg, displayName String, Boolean isPrimary)


in Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadDataToServerInfo()


in Microsoft.Crm.Application.Outlook.Config.ServerForm. < InitializeBackgroundWorkers > b__2 (Object sender, e DoWorkEventArgs)


in System.ComponentModel.BackgroundWorker.OnDoWork (e DoWorkEventArgs)


in System.ComponentModel.BackgroundWorker.WorkerThreadStart (argomento oggetto)

Causa

Questo problema si verifica se si utilizza una versione di Microsoft Online Services Sign-in Assistant è compatibile con Microsoft Dynamics CRM 2011 o Microsoft Dynamics CRM 2013. Configurazione di Microsoft Dynamics CRM per i client Outlook e la connessione a un'istanza di Microsoft Dynamics CRM Online, sola versioni supportate di Microsoft Online Services Sign-in Assistant sono 7.250.4259.0, 7.250.4287.0e 7.250.4303.0.

Risoluzione

Per risolvere questo problema, eseguire le seguenti operazioni:

1. fare clic su Start, digitare appwiz. cple premere INVIO per aprire l'elemento programmi e funzionalità nel Pannello di controllo.

2. la disinstallazione di Microsoft Online Services Assistente per l'accesso se la versione non corrisponde a 7.250.4259.0, 7.250.4287.0o 7.250.4303.0.

3. scaricare e reinstallare la versione 7.250.4303.0 dell'Assistente di accesso Microsoft Online Services.

4. riavviare la workstation e configurare Microsoft Dynamics CRM per Outlook verificare che il problema viene risolto.

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

×