Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Si consideri lo scenario seguente:

  • Utilizzare il servizio DFSR Distributed File System Replication () in un ambiente di dominio basato su Windows Server 2012.

  • Si dispone di un gruppo di replica di File System distribuito (DFS) nell'ambiente di dominio.

  • Utilizzare il servizio DFSR per replicare i file nel gruppo di replica DFS. Le dimensioni di alcuni file sono di grandi dimensioni. Ad esempio, la dimensione di un file è 10 gigabyte (GB).


In questo scenario, i file di grandi dimensioni non possono essere replicati.

Nota: In genere questo problema si verifica quando la connessione di replica viene aperto e chiuso frequentemente. Ciò potrebbe essere causato da un processo di replica pianificata o la connettività di rete poco affidabili. Nel Registro di debug DFSR, vi sono informazioni indicante la copia del file replicato parziale viene salvata e quindi rilasciata.

Inoltre, le informazioni riportate di seguito viene registrate nel Registro di debug DFSR:

Data file candidati di tempo 2376 882 RDCX [avvisa] Abandoning di Rdc::SeedFile::Initialize (ignorato).
UID:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v103 gvsn:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v104 il nome del file:
ri2k3-dc1.vhd csId:{A739B084-9C47-4514-97DB-D8E4344D6438}
Candidate(uid:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v103
gvsn:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v104
fileName:104-{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v103-{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v104-Partial.frx)
+ [Error:9048(0x2358) StageReader::Serialize staging.cpp:529 2376 C i dati compressi non è valido]
+ [Error:9048(0x2358) Rdc::StagingClosure::Run rdc.cpp:3947 2376 C i dati compressi non è valido]
+ [Error:9048(0x2358) Rdc::Common::StageFile rdc.cpp:3574 2376 C i dati compressi non è valido]
+ [Error:9048(0x2358) StreamToIndex rdc.cpp:529 2376 C i dati compressi non è valido]
+ [Error:9048(0x2358) SignatureGenerator rdc.cpp:279 2376 C i dati compressi non è valido]
+ [Error:9048(0x2358) XpressUncompressReader::Read xpressstreams.cpp:1379 2376 C i dati compressi non è valido]
+ [Error:9048(0x2358) XpressUncompressReader::Read xpressstreams.cpp:1323 2376 C i dati compressi non è valido

Causa

Questo problema si verifica perché il servizio DFSR considera la copia parziale del file replicato come non valido. Quando un file di grandi dimensioni non può essere replicato in un'unica sessione, DFSR Salva una copia parziale del file replicato in modo che il processo di replica può continuare dal punto di interruzione. Poiché la copia del file parziale è considerata valida da DFSR, DFSR deve riavviare il processo di replica. Tuttavia, la connessione di replica non viene mai aperto un tempo sufficiente per completare il processo di replica. Di conseguenza, i file di grandi dimensioni non possono essere replicati.

Risoluzione

Per risolvere questo problema, applicare questo hotfix. Una volta applicato l'hotfix, la replica viene ripresa una copia del file parziale in cui è stata interrotta non è necessario ricominciare dall'inizio.

Informazioni sull'hotfix

Un hotfix supportato è disponibile dal supporto Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario disporre di Windows Server 2012 è installato.

Richiesta di riavvio

Non è necessario riavviare il computer dopo avere applicato questo hotfix.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce eventuali hotfix precedentemente rilasciato.

La versione inglese (Stati Uniti) di questo hotfix consente di installare file con gli attributi elencati nelle tabelle seguenti. Le date e ore per questi file sono elencate nel tempo universale coordinato (UTC). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e gli orari possono cambiare quando si eseguono determinate operazioni sui file.

Note e informazioni sui file di Windows 8 e Windows Server 2012

Importante Aggiornamenti rapidi di Windows 8 e Windows Server 2012 sono inclusi nel pacchetto stesso. Tuttavia, solo "Windows 8" è elencato nella pagina richiesta Hotfix. Per richiedere il pacchetto di hotfix che si applica a uno o entrambi i sistemi operativi, selezionare l'hotfix elencato nella pagina in "Windows 8". Fare sempre riferimento alla sezione "Si applica a" negli articoli per determinare il sistema operativo effettivo a cui si applica ogni aggiornamento rapido .

  • I file relativi a un prodotto, un'attività cardine (RTM, SPn) e un ramo (LDR, GDR specifici) del servizio possono essere identificati esaminando i numeri di versione del file come indicato nella tabella seguente.

    Versione

    Prodotto

    Attività cardine

    Ramo del servizio

    6.2.920 0,16 xxx

    Windows 8 e Windows Server 2012

    RTM

    GDR

    6.2.920 0,20 xxx

    Windows 8 e Windows Server 2012

    RTM

    LDR

  • I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono elencati separatamente nella sezione "Ulteriori informazioni sui file per Windows 8 e Windows Server 2012". MUM e file MANIFEST e i file di catalogo (CAT) di protezione associato, sono estremamente importanti per mantenere lo stato dei componenti aggiornati. I file catalogo di protezione elencati senza attributi sono firmati con firma digitale Microsoft.

Per tutte le versioni basate su x64 supportate di Windows Server 2012

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Dfsrprovs.mof

Non applicabile

75,761

25-Jul-2012

20:12

Non applicabile

Dfsrress.dll

6.2.9200.16384

2.048

26-Jul-2012

02:33

x64

Dfsrs.exe

6.2.9200.20899

4,724,736

19-Dec-2013

00:24

x64

Ulteriori informazioni sui file

Ulteriori informazioni sui file per Windows Server 2012

File aggiuntivi per tutte le versioni basate su x64 supportate di Windows Server 2012

Nome del file

Amd64_2beae9088974fa54abf8919396ec92cd_31bf3856ad364e35_6.2.9200.20899_none_f6ff7a3e18a75efe.manifest

Versione del file

Non applicabile

Dimensione del file

712

Data (UTC)

19-Dec-2013

Ora (UTC)

23:28

Piattaforma

Non applicabile

Nome del file

Amd64_microsoft-windows-dfsr-core-serveronly_31bf3856ad364e35_6.2.9200.20899_none_f6d92e444aacb376.manifest

Versione del file

Non applicabile

Dimensione del file

37,695

Data (UTC)

19-Dec-2013

Ora (UTC)

23:28

Piattaforma

Non applicabile


Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×