Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Si consideri lo scenario seguente:

  • Installare le schede di Commerce Server BizTalk Server in un computer che esegue Microsoft BizTalk Server. Queste schede sono inclusi in Microsoft Commerce Server 2009 R2.

  • Creare e configurare gli ordini di un indirizzo di ricezione per un endpoint utilizzando l'Adapter BizTalk per gli ordini per ricevere ordini da Commerce Server 2009 R2.


In questo scenario, l'indirizzo di ricezione per l'endpoint potrebbe smettere di elaborazione dei messaggi in modo discontinuo. Questa condizione persiste, è necessario riavviare l'endpoint.

Inoltre, nel registro dell'applicazione viene registrato un messaggio di errore analogo al seguente:

Tipo di evento: errore
Origine evento: BizTalk Server 2009
Categoria evento: BizTalk Server 2009
ID evento: 5673
Descrizione:
Il motore di messaggistica ha ricevuto un errore dall'adapter di trasporto "adapter_name" notifica l'adattatore dell'evento BatchComplete. Motivo "Riferimento di oggetto non impostato su un'istanza di un oggetto."

Nota: Il segnaposto di adapter_name in questo messaggio di errore è il nome specificato per l'Adapter BizTalk per gli ordini di BizTalk Server, ad esempio gli ordini di Commerce Server.

Causa

Questo problema si verifica perché uno stato di attesa infinito può verificarsi quando l'Adapter BizTalk per gli ordini non riceve segnali da altre parti durante una transazione. In questo caso, la scheda interrompe il polling di servizi Web dell'ordine di Commerce Server.

Risoluzione

Per risolvere questo problema, applicare questo hotfix. Dopo avere applicato questo hotfix, una nuova voce del Registro di sistema è stato introdotto per poter configurare il valore di timeout della transazione per l'Adapter BizTalk per gli ordini. Per attivare questo hotfix, vedere la sezione attivare l'hotfix .

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.


Prerequisiti

Per applicare questo hotfix, è necessario disporre di schede di Commerce Server per BizTalk Server installato.


Attivare l'aggiornamento rapido

Per attivare questo hotfix, attenersi alla seguente procedura:

  1. Riavviare l'endpoint.

  2. Applicare questo hotfix.

  3. Nel Registro di sistema, individuare la seguente sottochiave:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\CommerceServer\9.0\BizTalk Adapters\Orders\subkeyNota: In questo caso, il segnaposto sottochiave è il valore specificato nelle proprietà del trasporto di ricezione dell'ordine.

  4. Aggiungere la seguente voce del Registro di sistema e il valore della sottochiave:

    Nome della stringa di valore: TransactionTimeoutMinutes
    Stringa dati valore: 5
    Nota: Quando si imposta il valore di timeout per TransactionTimeoutMinutes, non impostare il valore troppo piccolo. Assicurarsi di impostare il valore è maggiore del valore di timeout di Microsoft Distributed Transaction Coordinator (MSDTC). Se si imposta il valore troppo piccolo, potrebbe verificarsi un timeout prima di BizTalk Server può completare l'elaborazione di ordini. Inoltre, non impostare il valore troppo grande, poiché la scheda attenderà che lungo prima che il timeout e continua.


Dopo aver attivato questo hotfix, un messaggio di errore analogo al seguente viene registrato nel registro dell'applicazione quando si verifica un timeout di transazione:

Nome registro: applicazione
Origine: L'Adapter di ricezione di ordini di Commerce Server
Data: Dataora
ID evento: 0
Categoria di attività: nessuno
Livello: errore
Parole chiave: classico
Descrizione:
SubmitBatch: Si è verificato il timeout di transazione con il valore di timeout di 300000

Nota: Il valore di timeout nel messaggio di errore è in millisecondi.



Informazioni sul riavvio

Non è necessario riavviare il computer dopo avere applicato questo hotfix. Tuttavia, è necessario riavviare l'istanza dell'host BizTalk dopo aver applicato questo hotfix.


Informazioni sulla sostituzione

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Microsoft.commerceserver.adapter.orders.receiveadapter.dll

9.0.4260.217

51,864

18-Feb-2013

20:28

x86

Nota: A causa delle dipendenze tra file, la correzione più recente contenente i file può contenere anche file aggiuntivi.

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

Se si desiderano ulteriori informazioni sulle schede di BizTalk Server, visitare la seguente pagina Web Microsoft Developer Network (MSDN):

Commerce Server adapter per BizTalk Server

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×