FIX: Messaggio di errore "Sconosciuto" per le istanze di messaggio EDI sospese in BizTalk Server 2009

Sintomi

Si consideri lo scenario seguente:

  • Utilizzare i componenti nativi EDI Electronic Data Interchange () in Microsoft BizTalk Server 2009 per ricevere i messaggi EDI.

  • Si ricevono messaggi EDI in ingresso che utilizzano più schemi. Ad esempio, un messaggio in ingresso utilizza Schema 837 Professional 5010.

  • Il messaggio non riesce in pipeline EDI e viene sospesa l'istanza del messaggio EDI.


In questo scenario, non viene generata alcuna informazione di errore utili. Tuttavia, un messaggio di errore analogo al seguente viene registrato nel registro eventi di Console di amministrazione di BizTalk Server:

Un messaggio di output del componente "Sconosciuto" in pipeline di ricezione "Microsoft.BizTalk.Edi.DefaultPipelines.EdiReceive, Microsoft.BizTalk.Edi.EdiPipelines, versione = 3.0.1.0, Culture = neutral, PublicKeyToken = 31bf3856ad364e35" venga sospesa a causa del seguente errore:

Sconosciuto.

Il numero di sequenza del messaggio sospeso è 1.

Causa

Questo problema si verifica a causa di un problema nella logica di suddivisione di interruzione documento secondario utilizzato in più schemi.

Risoluzione

Informazioni sull'aggiornamento cumulativo

La correzione di questo problema è incluso nell' aggiornamento cumulativo 7 per BizTalk Server 2009.

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Riferimenti

Vedere un problema analogo in Microsoft BizTalk Server 2010.

Un problema analogo in Microsoft BizTalk Server 2006 R2, vedere.

Per ulteriori informazioni, vedere gli aggiornamenti rapidi di BizTalk Server e supporta l'aggiornamento cumulativo .

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×