Gli appuntamenti, i contatti e le attività non possono essere sincronizzati per la cassetta postale perché l'utente della cassetta postale non dispone di autorizzazioni sufficienti per questa cassetta postale

Questo articolo fornisce una soluzione a un errore che si verifica quando si tenta di testare e abilitare una cassetta postale in Dynamics 365.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4052824

Sintomi

Quando si tenta di testare e abilitare una cassetta postale in Dynamics 365, viene registrato l'avviso seguente:

"Appuntamenti, contatti e attività non possono essere sincronizzati per il nome> della cassetta postale <perché l'utente della cassetta postale non dispone di autorizzazioni sufficienti per questa cassetta postale.

Email Codice di errore del server: Crm.80048306.Privilegi insufficienti per accedere all'oggetto microsoft Dynamics 365 o eseguire l'operazione richiesta."

Se si sceglie di visualizzare i dettagli, vengono visualizzati i dettagli aggiuntivi seguenti:

"T:195
ActivityId: <GUID>
>Eccezione: eccezione non gestita: Microsoft.Crm.CrmSecurityException: SecLib::AccessCheckEx non riuscita. Restituito hr = -2147187962, ObjectID: <GUID>, OwnerId: <GUID>, OwnerIdType: 8 e CallingUser: <GUID>. ObjectTypeCode: 4120, objectBusinessUnitId: <GUID>, AccessRights: WriteAccess at Microsoft.Crm.BusinessEntities.SecurityLibrary.AccessCheckEx2(ExecutionContext context, SecurityPrincipal principal, SecurityPrincipal ownerPrincipal, Guid objectId, Int32 objectTypeCode, Guid objectBusinessUnitId, AccessRights rights) in Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncUtility.HasExchangeSyncIdMappingAccess(Guid userId, Int32 userIdTypeCode, IACTProviderContext orgContext) all'indirizzo Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncWorker.PerformPreMailboxSyncChecks() all'indirizzo Microsoft.Crm.Asynchronous.EmailConnector.ExchangeS..."

Causa

L'utente Dynamics 365 associato alla cassetta postale non dispone di privilegi sufficienti. Spesso è causato dal fatto che all'utente non è assegnato un ruolo di sicurezza o al ruolo di sicurezza manca l'accesso in lettura o scrittura a livello di utente all'entità Cassetta postale.

Importante

Verificare che il proprietario del record della cassetta postale sia uguale all'utente. Esempio: se la cassetta postale è una cassetta postale utente per Paul Cannon, verificare il valore Proprietario all'interno del record della cassetta postale per Paul Cannon come Paul Cannon. Se si tratta di un altro utente, l'utente potrebbe non avere accesso alla cassetta postale dell'utente.

Risoluzione

Per correggere il problema, attenersi alla procedura seguente:

  1. Come utente con il ruolo Amministratore di sistema, aprire il record della cassetta postale in Dynamics 365.

    Nota

    L'avviso include un collegamento al record della cassetta postale.

  2. Verificare che il campo Proprietario nel modulo cassetta postale sia popolato con il nome dell'utente. Se un altro utente è elencato, modificarlo in modo che corrisponda a questo utente.
  3. Selezionare il collegamento all'interno del campo Proprietario per aprire il record Utente per l'utente proprietario.
  4. Selezionare Gestisci ruoli per visualizzare i ruoli di sicurezza assegnati all'utente.
  5. Passare a Impostazioni, selezionare Sicurezza e quindi Ruoli di sicurezza.
  6. Aprire i ruoli trovati nel passaggio 4. Vedere Errore PrivilegeDenied quando si usa la sincronizzazione Server-Side per un elenco dei privilegi necessari e verificare che il ruolo di sicurezza dell'utente contenga questi privilegi.
  7. Dopo aver verificato che l'utente sia il proprietario del record della cassetta postale e che il ruolo di sicurezza contenga i privilegi necessari, selezionare di nuovo il pulsante Test & Abilita cassetta postale all'interno del record della cassetta postale. Se il test non ha esito positivo, esaminare il messaggio visualizzato nella sezione Avvisi.