Sintomi
Si consideri lo scenario seguente:
-
Si dispone di un Windows Server 2008 R2 Service Pack 1 (SP1)-basata su server Remote Desktop Services (RDS).
-
Gli account utente sono configurati per utilizzare profili comuni quando gli utenti accedono al server licenze utilizzando una sessione di Remote Desktop Protocol (RDP).
-
Attivare la seguente impostazione di criteri di gruppo eliminare le copie memorizzate nella cache dei profili utente comuni quando si disconnettono gli utenti:
Computer Configuration\Administrative Templates\System\User Profiles\Delete cache le copie dei profili comuni
-
Si esegue un programma di monitoraggio che periodicamente esegue una query di Strumentazione gestione Windows (WMI) sul server RDS.
In questo scenario, i profili utente comuni sono danneggiati e gli utenti non possono accedere al server.
Causa
Questo problema è causato da una race condition che si verifica quando il thread di WinLogon tenta di ottenere i profili comuni dal server comune ed eseguire la query WMI allo stesso tempo.
Risoluzione
Informazioni sull'hotfix
Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.
Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix. Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.
Prerequisiti
Per applicare questo hotfix, è necessario eseguire Windows Server 2008 R2 SP1.
Per ulteriori informazioni su come ottenere un service pack di Windows 7 o Windows Server 2008 R2, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:976932 Informazioni sul Service Pack 1 per Windows 7 e Windows Server 2008 R2
Informazioni del Registro di sistema
Per applicare questo hotfix, non è necessario apportare modifiche al Registro di sistema.
Richiesta di riavvio
Dopo avere applicato questo hotfix, è necessario riavviare il computer.
Informazioni sulla sostituzione dell'aggiornamento rapido
Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.
La versione globale di questo hotfix consente di installare file con gli attributi elencati nelle tabelle seguenti. Le date e ore per questi file sono elencate nel tempo universale coordinato (UTC). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e gli orari possono cambiare quando si eseguono determinate operazioni sui file.
Note di informazioni file di Windows Server 2008 R2Importante Aggiornamenti rapidi di Windows 7 e aggiornamenti rapidi di Windows Server 2008 R2 sono inclusi nel pacchetto stesso. Tuttavia, gli aggiornamenti rapidi nella pagina richiesta Hotfix sono elencati in entrambi i sistemi operativi. Per richiedere il pacchetto di hotfix che si applica a uno o entrambi i sistemi operativi, selezionare l'hotfix elencato nella pagina in "Windows 7 e Windows Server 2008 R2". Fare sempre riferimento alla sezione "Si applica a" negli articoli per determinare il sistema operativo effettivo a cui si applica ogni aggiornamento rapido .
-
I file relativi a un prodotto specifico, SR_Level (RTM, SPn) e un ramo del servizio (LDR, GDR) possono essere identificati esaminando i numeri di versione del file come indicato nella seguente tabella:
Versione
Prodotto
Attività cardine
Ramo del servizio
6.1.760
1.22 xxxWindows Server 2008 R2
SP1
LDR
-
I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono elencati separatamente nella sezione "Ulteriori informazioni sui file per Windows Server 2008 R2". MUM e file MANIFEST e i file di catalogo (CAT) di protezione associato, sono estremamente importanti per mantenere lo stato del componente aggiornato. I file catalogo di protezione elencati senza attributi sono firmati con firma digitale Microsoft.
Per tutte le versioni basate su x64 supportate di Windows Server 2008 R2
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
---|---|---|---|---|---|
Cimwin32.dll |
6.1.7601.22340 |
2,058,752 |
25-May-2013 |
20:51 |
x64 |
Per tutte le versioni basate su IA-64 supportate di Windows Server 2008 R2
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
---|---|---|---|---|---|
Cimwin32.dll |
6.1.7601.22340 |
4,281,856 |
25-May-2013 |
20:00 |
IA-64 |
Stato
Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".
Ulteriori informazioni
Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:
824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
Ulteriori informazioni sui file per Windows Server 2008 R2
File aggiuntivi per tutte le versioni basate su x64 supportate di Windows Server 2008 R2
Nome del file |
Amd64_bba626cc2058247522c9557d6dad01fd_31bf3856ad364e35_6.1.7601.22340_none_a384ccd5038394fc.manifest |
Versione del file |
Non applicabile |
Dimensione del file |
723 |
Data (UTC) |
26-May-2013 |
Ora (UTC) |
02:23 |
Piattaforma |
Non applicabile |
Nome del file |
Amd64_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7601.22340_none_2e36060535e90633.manifest |
Versione del file |
Non applicabile |
Dimensione del file |
5,228 |
Data (UTC) |
25-May-2013 |
Ora (UTC) |
21:26 |
Piattaforma |
Non applicabile |
File aggiuntivi per tutte le versioni basate su IA-64 supportate di Windows Server 2008 R2
Nome del file |
Ia64_a703e43c8ce0db40a2e3fa4d84053ba5_31bf3856ad364e35_6.1.7601.22340_none_d731ee8ec5f719e7.manifest |
Versione del file |
Non applicabile |
Dimensione del file |
721 |
Data (UTC) |
26-May-2013 |
Ora (UTC) |
02:23 |
Piattaforma |
Non applicabile |
Nome del file |
Ia64_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7601.22340_none_d2190e777d899df9.manifest |
Versione del file |
Non applicabile |
Dimensione del file |
5,226 |
Data (UTC) |
25-May-2013 |
Ora (UTC) |
20:43 |
Piattaforma |
Non applicabile |