Il programma di installazione web.NET Framework 4.7 per Windows

In questo articolo viene descritto il programma di installazione web di Microsoft.NET Framework 4.7 per Windows 7 Service Pack 1 (SP1) di Windows 8.1, Windows 10 anniversario Update (versione 1607), 2016 di Windows Server, Windows Server 2008 R2 SP1, Windows Server 2012 e Windows Server 2012 R2.

Informazioni di.NET Framework 4.7

Il 4.7 di.NET Framework è altamente compatibile e in loco per il.NET Framework 4, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1 e 4.6.2.

Il programma di installazione web è un pacchetto di piccole dimensioni che determinate automaticamente e Scarica solo i componenti che si applicano a una determinata piattaforma. Il programma di installazione web viene installato anche il language pack corrispondente alla lingua del sistema operativo dell'utente.

Il pacchetto non in linea può essere utilizzato quando il programma di installazione web non può essere utilizzato per mancanza di connettività Internet. Questo pacchetto è maggiore il programma di installazione web e non include i language pack.

Quando si installa questo pacchetto, è possibile visualizzare gli aggiornamenti installati, o di pacchetti in base al sistema operativo:

  • In Windows 7 SP1 e Windows Server 2008 R2 SP1, il Microsoft.NET Framework 4.7 viene elencato come prodotto installato sotto l'elemento programmi e funzionalità nel Pannello di controllo.

  • In Windows Server 2012, è elencato come aggiornamento per Microsoft Windows (KB3186505) sotto la voce Aggiornamenti installati nel Pannello di controllo.

  • In Windows 8.1 o Windows Server 2012 R2, è elencato come aggiornamento per Microsoft Windows (KB3186539) sotto la voce Aggiornamenti installati nel Pannello di controllo.

  • In Windows 10 1607 versione, è elencato come aggiornamento per Microsoft Windows (KB3186568) sotto la voce Aggiornamenti installati nel Pannello di controllo.

Nota

Le funzionalità di.NET Framework 4.7 WPF si basa su D3DCompiler_47.dll. Per impostazione predefinita, questa D3DCompiler_47.dll non è presente in Windows 7 SP1, Windows 2008 R2 SP1 o Windows 2012. Queste piattaforme richiedono pertanto il D3DCompiler_47.dll per l'installazione per le funzionalità di.NET Framework 4.7 WPF a funzionare come previsto. Per informazioni sull'installazione di D3DCompiler_47.dll, vedere i problemi conosciuti.

Informazioni sul download

I seguenti file sono disponibili per il download da Microsoft Download Center:

DownloadDownload del pacchetto di installazione web di Microsoft.NET Framework 4.7.

Per il.NET Framework 4.7 (programma di installazione non in linea):

DownloadDownload del pacchetto di installazione non in linea di Microsoft.NET Framework 4.7.

Per ulteriori informazioni su come scaricare i file di supporto Microsoft, vedere Come ottenere file di supporto Microsoft dai servizi online .

Microsoft ha analizzato questo file per individuare eventuali virus. Microsoft ha utilizzato il software antivirus più recente disponibile alla data in cui il file è stato registrato. Il file è archiviato in un server con protezione avanzata che impedisce modifiche non autorizzate al file.

Ulteriori informazioni

Per ulteriori informazioni su 4.7 di.NET Framework, vedere problemi noti di 4.7 di.NET Framework .

Questa versione di.NET Framework esecuzioni side-by-side in.NET Framework 3.5 SP1 e versioni precedenti, ma esegue un aggiornamento sul posto per i 4 di.NET Framework, .NET Framework 4.5, di.NET Framework 4.5.1, di.NET Framework 4.5.2, il 4.6 di.NET Framework, di.NET Framework 4.6.1 e di.NET Framework 4.6.2.

Opzioni della riga di comando per questo aggiornamento

Per informazioni sulle varie opzioni della riga di comando supportate da questo aggiornamento, vedere la sezione "Opzioni della riga di comando" in Guida alla distribuzione di.NET Framework per gli sviluppatori .

Richiesta di riavvio

Potrebbe essere necessario riavviare il computer dopo l'installazione di questo software, se vengono utilizzati i file interessati. Si consiglia di chiudere tutte le applicazioni che utilizzano il.NET Framework prima di applicare questo aggiornamento.

Si applica a

Il.NET Framework 4.7 (programma di installazione Web) supporta i seguenti sistemi operativi:

  • Windows Server 2016 (x64)

  • Windows Server 2012 R2 (x64)

  • Windows Server 2012 (x64)

  • Windows Server 2008 R2 Service Pack 1 (x64)

  • 1607 versione 10 di Windows (x86 e x64)

  • Windows 8.1 (x86 e x64)

  • Windows 7 Service Pack 1 (x86 e x64)

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×