Sintomo
Durante la distribuzione di app per Outlook da Dynamics CE verrà visualizzato un errore in rosso davanti agli utenti cassetta postale "Problema durante l'aggiunta a Outlook". Se si fa clic su ulteriori dettagli, viene visualizzato il messaggio "Operazione origine dati non valida".
Se si passa a Gestione componenti aggiuntivi da una cassetta postale degli utenti, verrà visualizzato il seguente errore:
"Impossibile individuare l'oggetto directory virtuale Accesso client con InternalURl contrassegnato per ECP, servizio."
Nota: affinché un componente aggiuntivo di Office venga distribuito alla cassetta postale di un utente in Exchange, "AppsForOfficeEnabled" deve essere true. È possibile utilizzare il comando seguente per controllare le impostazioni di configurazione tramite Exchange Management Shell(EMS).
Proprietà Get-OrganizationConfig . App Format-ListForOfficeEnabled
Causa
Ciò è dovuto alla ricerca di individuazione dall'interfaccia di amministrazione di Exchange (EAC). Ogni volta che la ricerca di individuazione viene eseguita per la prima volta utilizzando EAC in Exchange 2013, controllerà i seguenti 6 URL interni in background e lo memorizzerà nella cache locale
URL trovato: https://e15-cas.contoso.com/owa URL trovato: https://e15-cas.contoso.com/ecp URL trovato: https://e15-cas.contoso.com/EWS/Exchange.asmx URL trovato: https://e15-cas.contoso.com/Microsoft-Server-ActiveSync URL trovato: https://e15-cas.contoso.com/OAB URL trovato: https://e15-cas.contoso.com/mapi [GlobalServiceUrls.DiscoverUrlsIfNeeded] Trovato correttamente tutti i VDir necessari
Risoluzione
Assicurarsi che tutte le directory virtuali necessarie siano presenti e che gli URL interni siano pubblicati in tali directory virtuali.
Per ulteriori informazioni su come configurare le directory virtuali di Exchange, vedere l'URL di folllowing:https://docs.microsoft.com/en-us/Exchange/plan-and-deploy/post-installation-tasks/configure-mail-flow-and-client-access?view=exchserver-2019#step-4-configure-external-urls