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Sintomi

Quando si prova ad aprire una Knowledge base (KB) per la gestione del dominio o per altre attività nel client qualità dati in Microsoft SQL Server 2012, viene visualizzato il messaggio di errore seguente:

Nel database esiste già una configurazione con nome "recente: KB: dominio\nomeutente". ID messaggio: ConfigServiceConfigurationAlreadyExists

Causa

Questo problema si verifica perché, anche se il confronto tra il nome utente corrente e l'elenco dei nomi utente recenti fa distinzione tra maiuscole e minuscole, il nome utente archiviato in un elenco interno delle Knowledge Base aperte recenti non fa distinzione tra maiuscole e minuscole. Ad esempio, seguire questa procedura:

  1. Per accedere a Windows, è possibile usare un account denominato "dominio\utente1" una sola volta.

  2. Si usa il client qualità dati con successo.

  3. Disconnettersi da Windows e quindi accedere di nuovo a Windows usando un account denominato "DOMAIN\USER1."

  4. Si prova a usare il client qualità dati per aprire una Knowledge base.

L'errore può verificarsi a causa di una differenza nelle lettere maiuscole e minuscole usate quando l'utente ha digitato il proprio nome utente per accedere a Windows.

Risoluzione

Informazioni sull'aggiornamento cumulativo

SQL Server 2012

La correzione di questo problema è stata rilasciata per la prima volta nell'aggiornamento cumulativo 1. Per altre informazioni su come ottenere questo pacchetto di aggiornamento cumulativo per SQL Server 2012, fare clic sul numero dell'articolo della Microsoft Knowledge Base seguente per visualizzare l'articolo:

2679368 Pacchetto di aggiornamento cumulativo 1 per SQL Server 2012Nota Poiché le build sono cumulative, ogni nuova versione di correzione contiene tutti gli hotfix e tutti gli aggiornamenti della sicurezza inclusi nella versione precedente di SQL Server 2012 FIX. Ti consigliamo di considerare l'applicazione della versione di correzione più recente che contiene questo hotfix. Per ulteriori informazioni, fare clic sul numero dell'articolo seguente per visualizzare l'articolo nella Microsoft Knowledge Base:

2692828 Build di SQL Server 2012 rilasciate dopo il rilascio di SQL Server 2012

Stato

Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".

Soluzione alternativa

Per ovviare a questo problema, utilizzare uno dei seguenti metodi:

  • Eliminare manualmente la voce dalla tabella interna per l'utente interessato. Per eseguire questa procedura, eseguire le operazioni seguenti:

    1. Eseguire l'istruzione seguente per verificare che siano presenti voci:

      SELECT * FROM DQS_MAIN.dbo.A_CONFIGURATION WHERE NAME like 'RecentList%';
    2. Eseguire l'istruzione seguente per eliminare il record per l'utente interessato:

      DELETE DQS_MAIN.dbo.A_Configuration WHERE NAME LIKE 'RecentList%<Domainname>\<Username>';

      In alternativa, eseguire l'istruzione seguente per eliminare tutti i record recenti per tutti gli utenti. Questo elimina l'elenco di tutti gli utenti recenti nel client.

      DELETE DQS_MAIN.dbo.A_Configuration WHERE NAME LIKE 'RecentList%';
  • Usare regole di capitalizzazione coerenti per specificare l'account utente quando si accede al computer client per la qualità dei dati.

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