La sincronizzazione di aggiornamento software non riesce con 502 Gateway non valido o Timeout Gateway 504 in WCM.log

Sintomi

Considerare lo scenario descritto di seguito:

  • Sul server del sito principale, si è installato un sito sistema ruolo che richiede l'accesso a Internet, ad esempio il punto di connessione. In alternativa, è stato configurato tali servizi cloud come Microsoft Store per lavoro o il gateway di gestione cloud (CMG).

  • Si dispone di un server proxy configurato per il server del sito principale.

  • Si dispone di un punto di aggiornamento software remoto (SUP) configurato per il sito principale.

In questo scenario, la sincronizzazione di aggiornamento software non riesce e nel WCM.log la seguente voce di errore viene registrata nel server del sito:

Il tentativo di connessione al server WSUS: REMOTESUP. CONTOSO.COM, porta: 8530, useSSL: False  Connessione remota non riuscita con eccezione ' System.Net.WebException: richiesta non riuscita con stato HTTP 504: Timeout Gateway. ~ ~ a Microsoft.UpdateServices.Administration.AdminProxy.CreateUpdateServer (oggetto [] args) ~ ~ a Microsoft.SystemsManagementServer.WSUS.WSUSServer.ConnectToWSUSServer (numero di porta stringa NomeServer, UseSSL Boolean, Int32)'. Se si tenta di utilizzare proxy  System. InvalidCastException: Impossibile eseguire il cast dell'oggetto di tipo 'Microsoft.ConfigurationManager.CloudBase.CMWebProxy' al tipo ' System.Net.WebProxy'.~~ in Microsoft.SystemsManagementServer.WSUS.WSUSServer.ConnectToWSUSServer (stringa NomeServer, UseSSL Boolean, Int32 NumeroPorta)  Configurazione remota non riuscita sul Server WSUS. ~

Nota: In alcuni casi, la voce di errore contiene "stato HTTP 502: Gateway non valido" invece di "stato HTTP 504: Timeout Gateway."

Causa

Questo problema si verifica perché il server del sito utilizza erroneamente il server proxy quando si connette in remoto SUP.

Risoluzione

Per risolvere questo problema, aggiornare alla Versione corrente di ramo 1906 di Configuration Manager.

Soluzione alternativa

Per aggirare il problema senza l'aggiornamento, utilizzare uno dei seguenti metodi:

  • Spostare il ruolo SUP al server del sito. Nota: Se si dispone di più di un SUP nel sito principale, utilizzare uno degli altri metodi.

  • Spostare i ruoli di sistema del sito che richiedono l'accesso internet a un server remoto e quindi rimuovere la configurazione del proxy dal server del sito.

  • Impostare temporaneamente il server proxy per consentire il traffico routing dal server del sito remoto SUP.

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